Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

For some reason, I am unable to install mass storage devices on my Windows 7 x64 machine. I see the error from the image below.

If I point directly at the usbstor.inf driver, I still get the error. If I copy the usbstor.inf and .sys files to another folder and point at it, I get a driver-not-signed warning, but the installation works correctly.

How do I fix this problem?

Enter image description here

share|improve this question
Look in Device manager, what is listed under Universal Serial Bus Controllers? Also run a – Moab Dec 25 '11 at 16:54
Have you tried more than one "mass storage device", or is it just one device you're having trouble with? If it's just one, does it work in other computers? – Ƭᴇcʜιᴇ007 Dec 25 '11 at 19:03
@techie007 This is with all Mass Storage Devices. – David Pfeffer Dec 26 '11 at 14:36
up vote 0 down vote accepted

For some reason, sometimes the file usbstor.inf disappears from the C:\Windows\INF directory. Manually putting it back fixes the problem.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.