Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

At some point recently NoScript started causing left mouse clicks to be ignored at random times. Sometimes it was so bad that I had to reload a page or even restart Firefox. The clicks are only ignored within the actual browser pane—the chrome widgets (history buttons, reload, location bar, etc.) never exhibit this behavior. I have proven this is NoScript by disabling the addon and running Firefox for a while without issue, and when I re-enable NoScript the issue returns.

I suspect it is supposed to be a new protection in NoScript, but it is obviously not working right for me.

Does anybody know what is going on, and how I can resolve it? I am willing to partially disable NoScript functionality—after all, partial functionality is better than none.

(I am asking here first because my prior experience on the NoScript forum has been exceedingly poor.)

Edit: This happens even on white listed sites.

share|improve this question
So, I know that you've landed on NoScript as a culprit, but, just as additional anecdata (which is why this is a comment, not an answer), I had a very similar problem as you. None of the extra buttons on my mouse would work within the Firefox browser window. I could enable and disable add-ons and have them occasionally start working again, but it never lasted. Reloading and restarting firefox never consistently brought them back. The fix was for me to uninstall the Logitech SetPoint drivers and everything has been great. – Jacob G Dec 26 '11 at 3:29
@JacobG: Yeah, I've been trying to consider other software as possible unusual interactions with Firefox and NoScript, but so far it appears to just be NoScript. – Heptite Dec 26 '11 at 4:15
I am having the same problem, unable to discover which NoScript option causes it. It is extremely annoying, the woraround is to right-click first, then left. – eudoxos Mar 6 '12 at 17:59
@eudoxos: That worked for me for a while, then sometimes stopped working reliably, especially on Facebook. In the end I just turned off NoScript. (Security being a tradeoff, NoScript was no longer worth the trade.) – Heptite Mar 6 '12 at 20:57
I cannot say for facebook, but generally interactive sites (trac, mapbuilder) get stuck. I still hope there are mre people with the same problem who will be able to comment. – eudoxos Mar 7 '12 at 15:09

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.