Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to set my Ruby version to be 1.9.2, but I can't change it from the system Ruby installation. What am I doing wrong?

My terminal output is:

$ rvm list

rvm rubies

=> ruby-1.9.2-p180 [ i386 ]

$ rvm use default
Using /usr/share/ruby-rvm/gems/ruby-1.9.2-p180
$ ruby -v
ruby 1.8.7 (2011-06-30 patchlevel 352) [i686-linux]
share|improve this question
add comment

2 Answers 2

up vote 6 down vote accepted

Normally under Ubuntu you need to do:

sudo update-alternatives --config ruby

That will allow you to set the default to any available version of ruby installed on your system. This is easily installed from repositories.

share|improve this answer
add comment

I would avoid setting particular version to default, better to use .rvmrc files with gemset and ruby version per project.

RVM way should be:

rvm 1.9.2-p180 --default
rvm use default

Also, I guess you might better to switch to 1.9.3. It is quite easy to do with rvm:

rvm install 1.9.3
  • RVM way will allow you to follow same approach on different platforms (Mac for example)
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.