Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Using Excel 2007, every time I press the "-" key, the extend selection mode is activated. Notice that in other programs the "-" key works as expected. This is very frustrating since I cannot input negative values.

I can disable extended mode by pressing [F8], but the next time I press "-" it comes back!

How can I solve this annoying problem?

share|improve this question
    
My guess is that you are using a RDP connection. If I am right, I have the solution. It is a bug of rdesktop versions 1.5 and 1.6. You have to downgrade to rdesktop 1.4 to solve the issue. –  Toc Oct 20 '09 at 15:34
add comment

7 Answers

I had this problem and found that there's actually a very simple solution.

Assuming you are having this problem with some sort of synergy client, what you need to do is press numlock on a keyboard attached to the machine having the problem. The extend selection issue is a direct result of the client machine's numlock being turned on and because synergy cannot turn it off.

Hope that helps someone. I struggled with this problem for over an hour. =)

share|improve this answer
add comment

I HAVE THE ANSWER!!

I have a linux based thin client connecting to a windows server via rdp. I have the extend problem in excel when using the numpad.

I too have struggled with this problem for many months and I fixed it by attacking the source of the problem.

The num pad minus and the minus on the main keyboard are different keycodes.

Remap the keycode in the registry and the problem goes away!!

Here is the regfile that will map the numpad - (minus) to the keyboard - (minus)

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout] "Scancode Map"=hex:00,00,00,00,00,00,00,00,02,00,00,00,0C,00,4A,00,00,00,00,00

You will need to reboot but it works straight away!!

share|improve this answer
add comment

Press NumLock+- (minus sign) to toggle this problem away.

Don't ask me why this works, because I'm still clueless, but I got the idea here when I was searching for answers.

share|improve this answer
add comment

I would try a few things to see if you can figure out the root of the problem.

Have you tried a new/different keyboard? Perhaps it's sending an F8 instead of a dash (who knows). You can also try an on-screen keyboard to see if using the - causes the same problem.

You might also check to see if there's a custom keyboard shortcut assigned in Excel. In Excel 2003, you can examine the shortcuts using these steps here.

Lastly, you can try a "Detect and Repair" on Excel/Office, which might be able to fix the problem.

  • In Excel 2003 or XP, select the "Detect and Repair" option from the help menu
  • In Excel 2007, select the Orb, "Excel Options" at the bottom of the menu, then the "Resources" tab, and then the "Diagnose" button.
share|improve this answer
add comment

Do you have Lotus 123 compatibility turned on? Should be able to check in Tools -> Options. I don't have Excel 2003 handy, but in 2007 it's on the Advanced tab.

share|improve this answer
add comment

It sounds like Autocorrect, but I can't imagine how it works. Go to the Office Button - Excel Options - Proofing Options - Autocorrect Options and see if there's an entry for the minus sign. If so, delete it. If that works, be sure to let us know what it was converting a minus into.

share|improve this answer
add comment

I believe I have the solution. It has to do with the NumLock status when you log in and out. Try logging off with NumLock off, turn NumLock on, and then log in. If NumLock turns off, turn it on again and check to see if it is fixed now.

Worked for me.

share|improve this answer
add comment

protected by slhck Oct 10 '12 at 14:38

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?