Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently ran into a problem similar to “CPU is not compatible with 64 bit mode” error trying to install Windows 7 (64 Bit) on VirtualBox. I am running 64 bit ubuntu 10.04 ltsand I can't install windows 7 64bit in Virtualbox 4.1.8

The answer suggests:

Enable the virtualization setting inside your computer BIOS. After that, you may install 64 Bit Windows 7 inside VirtualBox.

I have looked under Advanced> Cpu configuration and can't find an option to enable virtualisation. I have the Intel Core 2 Quad CPU Q8200 I Just checked the intel site and that processor does not support virtualisation. Does this mean that it is not possible to run windows 7 64 bit at all?

share|improve this question
    
Did you try the other answer? What BIOS do you have? –  slhck Dec 26 '11 at 11:18
    
I have the default Bios, I haven't changed since I got the motherboard.How can I check? –  andrew Dec 26 '11 at 11:33
    
Try with for example Microsoft Virtual PC. It (if I remember correctly) should work fine even without virtualization extensions. (or it could be that that's only for 32bit on 64bit) –  AndrejaKo Dec 26 '11 at 11:51
    
@AndrejaKo That's for, as you mentioned, only 32-bit guest on a 64-bit host. –  Sathya Dec 26 '11 at 12:02

2 Answers 2

Without Hardware Virtualization support, it's not possible to run 64-bit OS on a 32-bit host.

share|improve this answer
    
And what if your host is 64 bit? I don't think that comment is relevant to this particular situation. –  andrew Dec 26 '11 at 11:58
    
You would still need VT-x instructions to run a 64-bit guest on an Intel processor @andrew –  Sathya Dec 26 '11 at 12:02

You need to access the BIOS and enable virtualization in the CPU Configuration menu. Look for INTEL VT option and enable it.

If there is no INTEL VT option in your BIOS it may mean that your CPU does not have a vt flag and therefore is not capable of allowing full hypervisor virtualization. In that case you should install your Vbox guest 'para-virtualized' which cannot be 64-bit although 32-bit will work. In this case just say to yourself: "yeargh... who needs 64-bit anyway?"

If your BIOS doesn't allow you to enable virtualization, then simply install a 32-bit OS in VirtualBox. As documented here the relative benefit of 64-bit processing is not platform-wide. Besides, compared to the OS you are installing as a VM guest, the true power of your PC resides in the 64-bit version of Ubuntu you have running as the primary OS.

share|improve this answer
    
I start the computer hold down del.Then go to Advanced > Cpu configuration and I don't see INTEL VT –  andrew Dec 26 '11 at 11:39
    
Do note that in general not having Intel VT, Intel VT-x, Intel VT-d or similar in BIOS or UEFI does not necessarily mean that the hardware doesn't support the virtualization. It could that BIOS makers decided that users aren't going to need it and have removed the option to enable it. It happened to me and required some BIOS hacking. –  AndrejaKo Dec 26 '11 at 11:52
    
Hmm seems a bit dodgy to hack your bios and definitely out of my knowledge level. \ –  andrew Dec 26 '11 at 11:57
    
@andrew, no problem, just go ahead and install 32-bit Windows para-virtualized in VirtualBox - it will work fine. You have 64bit capability in your Ubuntu host which is the shizniz anyway :) –  venzen Dec 26 '11 at 13:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.