Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

About a year ago, I made rips of a bunch of my CD/DVD games and packed the originals away.

The problem is that now I'm trying to use WinXP Pro on VirtualBox on OSX Snow Leopard to play these iso images. I used dd in Terminal to make most or all of these images, but when I try to load them as a virtual cd in VirtualBox, they don't work.

I tried iso files I obtained by other means, and they worked fine, so I tried diskutil to find out more. The error message I get from trying to mount throught that is, "No mountable file systems." The only disk image that works was from a dvd.

I've forgotten the exact paths or options (probably none) I used when I made these images, but I know I used dd.

Reading around, I found the following link:

dd producing corrupt ISO images on Snow Leopard (whether invoked from a script or the shell)

From this, I'm guessing there's a high likelihood that I did the dd wrong (e.g. dd if=/dev/disk1 of=image.iso). If so, is there any way to manually repair these images, or will I have to download or re-dd these?

(Also, for my own learning, is this an OSX-specific dd bug/feature, or linux, too? Was I ignorant in thinking that dd if=/dev/whatever of=whatever.img would give a raw binary dump?)

share|improve this question
    
"Was I ignorant in thinking that dd if=/dev/whatever of=whatever.img would give a raw binary dump?" - not really. However, in your above example I can see dd if=/dev/disk1 - meaning, that it would actually be copying a partition (an offset from the start of the disk). Was that really the case or were you copying the whole disk to start with? –  XXL Jan 9 '12 at 16:27
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.