Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This is the Professional Model S. No need for drivers as it's plug and play, according to company. Here is what I have done up to now:

  • Windows 7 x64 tries to install drivers but fails.
  • "daskeyboard" and USB2.0 Hub" are listed under "Other devices" in Device Manager with an exclamation point. No luck in updating drivers from Device Manager.
  • Keyboard works fine in BIOS; does not work in Windows.
  • Keyboard works when plugged into a laptop; not my custom built desktop.
  • Flashed BIOS; still doesn't work.
  • Seems to get power for one second (I notice led lights during POST, then the lights shutoff)
  • Have tried multiple USB ports..
  • Have tried to set USB in BIOS to accept legacy USB.
  • Have tried to set USB in BIOS to Full Speed instead of High Speed.

I'll try anything short of re-installing Windows. Any other suggestions? Thanks.

share|improve this question

This happened to me. After hours of searching here is a solution what worked for me.

Seems i was missing usb.inf and usb.pnf files in C:\Windows\INF\

Browse to 'C:\Windows\System32\DriverStore\FileRepository\usb.inf_amd64_neutral_e2b28ecac19a29af'

Copy usb.inf and usb.PNF to 'C:\Windows\INF\' This step will require admin privileges

Unplug then plug the keyboard back in and it was recognized right away.

You can also try updating the drive manually like so.

  1. Update driver on unknown devices

  2. In Device Manager, right-click on the unknown device and select Properties

  3. Select Driver tab

  4. Click 'Update Driver' button

  5. Select 'Browse my computer for driver software'

  6. Enter 'C:\Windows\INF\' in the Search for driver software in this location field and click Next

share|improve this answer

Try removing the Devices and every bit of related software.

Ideal would be to go back to a restore point from before you first plugged in the keyboard.

And then maybe boot with the old keyboard and switch while Windows is running. See if you can monitor the 'loading drivers' popup and look in the eventlog afterwards.

share|improve this answer

Well, I found a work around - I'm using the serial adapter that came with it. I plugged it into the serial port, rebooted, and it works fine.

share|improve this answer

This happened to me today, it seems like windows update is looking for drivers on the internet using the ports 80 and 443... which in my case were being used by skype.

So, my solution was to quit skype for a bit until the keyboard was ready to use.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .