Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a problem with my Windows XP notebook. Suddenly sites like facebook and my email provider (gmx) throws unknown https certificates after trying to login. This error occures only on this xp machine, on my other computer (Windows 7) the websites do not throw any errors.

enter image description here

I am frightened that something has infected my Windows XP notebook. I could not find any viruses and have checked system32/drivers/etc/host file - There are no entries.

I also tested multiple browsers (IE and Firefox). I deactivated most plugins in the browsers.

Any suggestions are welcome. How can it be possible that https certificates are not trusted / corrupted suddenly?

share|improve this question

migrated from stackoverflow.com Dec 26 '11 at 18:10

This question came from our site for professional and enthusiast programmers.

    
A screen grab or a more specific error message from the certificate trust failure would be helpful. –  Garrett Dec 26 '11 at 18:16
    
@gman I added a screenshot to my question. Its the common https warning if the certificate is not trustful. But that can not be true for facebook. If more details are needed pls let me know what i can provide. Thanks –  Grrbrr404 Dec 26 '11 at 18:34
1  
Is your computer's clock correct? Check everything - year, month, day, even hour. –  grawity Dec 26 '11 at 20:07
1  
Open the certificate information and tells us the reason the browser claims the certificate is invalid/expired/ect –  Ramhound Dec 27 '11 at 12:45

2 Answers 2

up vote 5 down vote accepted

Usually failure to authenticate SSL Certificates are caused because your computer's time is before the date of certificate issue or after date of expiry, you should check your clock on the system tray, as well as check your BIOS for system time, for starters.

If that fails, check your browser settings and see if you've got any adverse settings applied to SSL settings.

If both of those fail, I assume its your browser, try a different one and try your luck :)

Good Luck :)

share|improve this answer
1  
It was system time - Was set to year 2012 instead of 2011 - I am impressed! :D Thank you for solution –  Grrbrr404 Dec 27 '11 at 20:02

Try to set your time zone.

  • Open Date and Time in Control Panel.
  • To change your time zone, click the Time Zone tab. In the box above the map, click the drop-down arrow, and then click your current time zone.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.