Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried this in my shortcut target input field but it doesn't work. The dialog box gives me an error message invalid path? "C:\Windows\System32\cmd.exe /C start /high /affinity 3 D:\The Elder Scrolls V - Skyrim\skse_loader.exe". Notice the spaces in the pathname. Is this the space character that need to be escaped?

share|improve this question

From your path

"C:\Windows\System32\cmd.exe /C start /high /affinity 3 D:\The/ Elder Scrolls V - Skyrim\skse_loader.exe"

The following part, and especially the slash seems to be most suspicious, since it is not allowed in path:

D:\The/ Elder

I would re-write your target using the short 8.3 name (it is the fake name in the example just to show what it should like):

"C:\Windows\System32\cmd.exe" /C start /high /affinity 3 D:\TheElde~1\skse_l~1.exe

share|improve this answer
    
I'm sorry, I was too fast. I've tried to escaped the space character with the slash character but I forget to delete in my question. About your suggesting it doesn't work. The path opens a terminal with the path but it is not starting the program. – Betterdev Dec 26 '11 at 19:16
    
Try converting your long path into short one and you won't need the quotes. You can use dir /x to see the short paths: you'll need that for your Elder Scroll folder and for executable only. – Alexander Galkin Dec 26 '11 at 19:32
    
Thanks, start option needs a title. – Betterdev Dec 26 '11 at 19:44

I was trying to do something similar in Windows 10 where I needed to append an argument to my Eclipse program shortcut's target, where the argument was a path with a space (C:\Program Files\Java\jdk1.7.0_80\jre\bin\javaw) [note the space in 'Program Files']...

If you just need to resolve the space in the path, surround the path in quotes.

So my argument became: "C:\Program Files\Java\jdk1.7.0_80\jre\bin\javaw"

Accepted Answer by @Phpdevpad helped me figure this out, but the quotes weren't focused on in that solution, so I made this separate Answer.

share|improve this answer
up vote 0 down vote accepted

Problem solved. The start option need a title to work: http://www.vistax64.com/gaming/197915-setting-processor-affinity-made-easy.html. C:\Windows\System32\cmd.exe /C START "Skyrim" /high /affinity 3 "D:\The Elder Scrolls V - Skyrim\skse_loader.exe"

share|improve this answer
    
Please mark this as the accepted answer to your question. – user33758 Dec 26 '11 at 23:56
    
Looks like you surrounding the path in quotes also may have helped. That's the part that helped solve my similar problem, as I just Answered separately (focusing on the quotes). – cellepo Jan 17 at 20:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.