Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a multi-file RAR archive with an SFV file which I have checked several times using a couple of different programs (QuickSFV and SFV Checker) and both keep changing their report each time I run them, computing different checksums for each file on each iteration.

Can anyone suggest why this may be, or how I might diagnose the cause?

Clarification: the issue is that the reported CRC for a file keeps changing each time I run it, where the file does not change. The context is an SFV file for a multi-file archive, and I'm computing the CRCs using QuickSFV/SFV Checker.

Update: I was able to extract the archive (which was originally failing because of a bad CRC, hence the need to check the SFV) by simply trying again and again until it worked, so the files were in fact valid and CRCs were randomly being computed incorrectly. I have no idea where the inconsistency is coming from though, and I'm interested to hear ideas.

Update: The computer had another spate of mini-freezes, when I restarted it complained about the 'header checksum' being incorrect and the file-system possibly being corrupt, and Windows did not boot. Further restarts eventually led to a 'no drive detected' message. I removed the side panels from my machine, unplugged the HD, blew on the slots/cables (I had a GameBoy, and old habits die hard), plugged it back in again and everything seems to be working once more (including resolving the original CRC inconsistencies). Perhaps the cable was a little loose, or some charge in the side-panels (somehow) was affecting the communication?

share|improve this question
    
You are unexpectedly getting different checksums for different files? –  Daniel Beck Dec 26 '11 at 19:37
    
I'm getting different checksums for the same file on different iterations, will clarify my question. –  connec Dec 26 '11 at 19:43
    
That's what I thought — thanks for clarifying. –  Daniel Beck Dec 26 '11 at 19:44
    
That the files were extracted does not mean the CRC was being computed incorrectly. They may appear to be okay, but still have garbage data in some or all parts. –  djs Dec 27 '11 at 5:57
add comment

1 Answer

First, remount readonly and take backups.

This happened to me and I was convinced it was the disk. It was not. I would check your power supply and your surge protector and then that you're getting the right power from the power source. In my case, it was the UPS/surge protector.

EDIT: I reread your question and I would not ignore this even if you were able to unzip the archive. In my case, I would get different md5sums on the same file but they would be similar. Small files would usually return the correct sum.

Example:

 md5sum file1  # returns abcde12345...
 md5sum file1  # returns bbcde12545...
 md5sum file1  # returns b1cde12395...
 md5sum file1  # returns abcde12345...
share|improve this answer
    
Interesting, I have no UPS/surge protector, so how could I check if my PSU is at fault? –  connec Dec 27 '11 at 15:52
    
In my case, I would get bad checksums about 80% of the time on any files larger than, say, 1M. My caution is to make sure it is bad data in the archive or some other software problem and not a subtle hardware issue. You might just sum a couple different files see if you can reproduce the inconsistent behavior elsewhere. I was also getting Kernel Paging Faults every couple hours or so; it was driving me mad. –  elcash Dec 27 '11 at 19:29
    
Well the archive contained an iso, which installed appropriately etc, so I'm reasonably convinced the data is fine. I'm also suffering freezes every now and again and sometimes when I restart I get a "bad header checksum" error which prevents booting... so it seems to be a pretty deep issue just not sure how to diagnose it :/ –  connec Dec 28 '11 at 1:31
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.