Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed the Slackware 13.37 package MPlayer-1.0rc4-i686-3sl.txz along with all of the available codecs, etc. I also have freetype-2.4.4-i486-1.txz installed for font rendering.

For my first dvd encode, I extracted subtitles with

mencoder movie.vob -nosound -ovc frameno -o nul -sid 0 -vobsubout subtitle-en -vobsuboutindex 0 -vobsuboutid en

and then played the 1st pass encode of the movie with

mplayer movie.1 -vobsub subtitle-en

All was well except that the subtitles are shown in this thick, crude font that is virtually unreadable because all the loops in various letters (a e o etc) are completely filled in. I've tried different ways of playing the movie, e.g.

mplayer movie.1 -vobsub subtitle-en -ass-force-style FontName=DejaVuSerif,Default.Bold=1
mplayer movie.1 -vobsub subtitle-en -subfont /usr/share/fonts/TTF/DejaVuSerif.ttf
mplayer movie.1 -vobsub subtitle-en -font /usr/share/fonts/TTF/DejaVuSerif.ttf

and I've tried recreating the subtitle files with those same options

$mencoder movie.vob -nosound -ovc frameno -o nul -sid 0 -vobsubout subtitle-en -vobsuboutindex 0 -vobsuboutid en -subfont /usr/share/fonts/TTF/DejaVuSerif.ttf
mencoder movie.vob -nosound -ovc frameno -o nul -sid 0 -vobsubout subtitle-en -vobsuboutindex 0 -vobsuboutid en -ass-force-style FontName=DejaVuSerif,Default.Bold=1

but there is no change in the subtitle rendering.

How should I do this? Ideally I would like the subtitles to show as plain black text with a white border or background, so that the text doesn't get lost in movie scenes that are predominantly black or white.

share|improve this question

I noticed that when I tried to play the movie I always got this message

VobSub: Can't open IFO file

Turns out that when you extract subtitles with the "-vobsubout" option it generates only a ".sub" and a ".idx" file, but to display the subtitles properly vobsub also needs a ".ifo" file. Mencoder won't produce it, but if you supply mplayer with the option "-ifo path to dvd ifo file" it displays properly, in my case as

mplayer movie.1 -vobsub en -ifo ./VIDEO_TS/VTS_01_0.IFO

So then I did

cp ./VIDEO_TS/VTS_01_0.IFO en.ifo

giving me the 3 files en.sub, en.idx and en.ifo. Then it played properly with just

mplayer movie.1 -vobsub en

Lastly I changed the 3 files named "en" to "movie" to match "movie.1" and found that then subtitles are played automatically with just

mplayer movie.1
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .