Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am able to connect to my machine using my external IP address from remote computers with no issue, but from my own computer I am unable to connect using my external IP.

How can I configure my router so that I can use my external IP to connect to my own network?

I read that some routers tend to drop packets where the source and destination IP are the same, apparently this is one, but can I change that somehow in the configuration or would I simply need a better router? The one I have (brand below) comes with FairPoint's DSL service.

For context

My network configuration is as follows:

- Westell VersaLink 7500 DSL modem/router (IP: 70.x.y.z)
-- Server (IP: 192.168.1.m)
---- Virtual Machine: (IP: 10.a.b.c)
-- Laptop (IP: 192.168.1.n)

So, I have a website running on port 8080 in the VM, I have port forwarding enabled on the VM software which forwards 8080 on the host ("Server" / 192.168.1.m) to 8080 on the VM (10.a.b.c). I am able to connect from (Server or Laptop) to the VM using (Server's IP or the VM's IP), and users outside my network are able to connect to the VM using my external IP (70.x.y.z) as I have port 8080 forwarded to Server's IP (192.168.1.m) in my router's settings.

share|improve this question
up vote 6 down vote accepted

Most likely, your router just doesn't support hairpin NAT. You can see if there's a firmware upgrade for your router.

share|improve this answer
Doesn't look like there's an upgrade. This router isn't the best quality either, I was thinking of getting a new one anyways. Thanks for posting the terminology though; didn't know there was a name for this. – Jake Petroules Dec 27 '11 at 4:06
Just a followup - I ended up buying a Cisco Linksys E1200, putting the Westell into bridged mode and everything works fine now. :) – Jake Petroules Jan 1 '12 at 23:23

Instead of putting your VM on it's own subnet, why not put it in bridge mode where it will grab an IP from your Router (or statically assign an IP on the same subnet as the router)? This way, even if your router doesn't have an update as David described, you don't have to immediately go out and get another router.

enter image description here

That way you can in this scenario, set a static IP of your VM and set your router to forward traffic from 8080 to the IP of your VM.

enter image description here

share|improve this answer
That'll just change my VM from having 10.x.y.z IP to having a 192.a.b.c IP, which is still within my LAN. My router is only going to be allowed one public IP by my ISP as far as I know. – Jake Petroules Dec 28 '11 at 0:56
That is true, but if you're looking to host multiple domains with a single IP address then you should look into Apache Reverse Proxy. With a Reverse Proxy, you can host multiple domains while pointing to their own VMs. – kobaltz Dec 28 '11 at 1:06
This is just for development/testing with a couple of co-workers. Basically I just wanted to avoid changing my internal IP to the domain I set up when I sent them links. I could just edit the hosts file but the router would have been the preferred solution. Either way not a huge problem. Interesting link, though. – Jake Petroules Dec 28 '11 at 3:17

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.