Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I connected a new display (ASUS VS229-H) to my computer using the DVI-cable which came with the display. I only see "no signal" on screen until the OS log-in screen is loaded. The previous display was connected via DVI too and did not show this problem. The VS229 takes DVI-D, which is what the previous monitor used too. The graphics card is a pretty old Radeon VE but I tried another, newer one showing the same problem.

Searching the web I only found many people having problems with the signal after the windows drivers have loaded (but that's the part that works fine with me) or problems being caused by using an unsuitable cable (But I used the one that came with it, and tried another one as well)

As a little hack I connected the VGA with the card and monitor too, so I can switch after loading but this is cumbersome.

share|improve this question
2  
Do you have graphics adapter embedded on your motherboard too? –  haimg Dec 27 '11 at 17:59
    
What @haimg said - probably it's not defaulting to that adapter, so it doesn't get used until Windows decides to enable it. –  Shinrai Dec 27 '11 at 18:14
    
yes there is VGA on the mainboard - but the former display did not show any of the problems and was connected to the same computer with the same card via DVI too. –  JanD Dec 27 '11 at 19:15

1 Answer 1

You need to go to your BIOS and either disable the built-in VGA adapter, or configure BIOS to prefer your Radeon VE over your onboard adapter. Your Radeon card may be referenced as "PCI adapter" in the BIOS.

This happens because once you remove the add-on adapter, BIOS resets this setting to prefer built-in adapter, and keeps it this way even if you insert a new add-on VGA adapter later.

share|improve this answer
    
Thanks. I'll try that, though (as commented on the question) the former monitor was connected exactly the same way and it got a signal during boot via DVI. And using a AGP card, mainboard VGA should be disabled anyway. –  JanD Dec 27 '11 at 21:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.