Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently got a Sony VAIO laptop (VPC-CA3C5E) for my wife, and I'm having problems with my Wi-Fi connection that I don't know how to troubleshoot.

This is the information I can think of:

  • The laptop works well, and the Wi-Fi seems to work well, but every now and then (every 10 minutes or so), web requests will start to fail, and a few seconds later, the Wi-Fi connection will show the yellow warning sign ("No Internet Access"). After that, sometimes it reconnects all by itself within a minute, sometimes you need to disconnect and reconnect, and all continues to work.
  • The router is the crappy default wireless router/modem that Virgin Media gave me. I'm not thrilled with it, but besides rebooting it every couple of weeks, it works well.
  • Signal "power" is quite high where we're using the latop. (4 out of 5 bars).
  • We have other 3 laptops, 1 desktop, and 3 cell phones connected to the same WiFi, and they all work perfectly. Many times when this disconnection happens, I'm sitting next to her with my own laptop and my connection keeps working perfectly.
  • This is not highly scientific, but it seems to happen more often when on battery than when plugged in. It did happen at least once while plugged in, though.
  • Another non-scientific one... It seems to happen more often in the bedroom than in the living room (where the router is), so this could be signal-power related. However, it gets 4 out of 5 bars in the bedroom, so that shouldn't be it
  • We returned the laptop and had it exchanged for a new one (exact same model, though). It is a different one, different serial number and all. Same problem. Again, this has not happened with any other device I've had in my house.
  • Nothing seemingly related shows up in Event Viewer, except for one "Name resolution for the name xxx timed out" from Source "DNS Client Events". This seems more the effect than the cause.
  • There don't seem to be updated drivers that I can download.
  • Trying it out in the Sony shop itself, it worked well. I haven't had the chance to test it thoroughly with other wifi's (since this is an intermittent problem, it's kind of hard to reproduce sometimes)

The adapter shows in Device Manager as "Atheros AR9485WB-EF Wireless Network Adapter"

UPDATE: I got a Linksys E3000 router, in case the Virgin Media router had something weird in its wi-fi. All the other devices in the house keep working perfectly. The VAIO laptop keeps doing exactly the same.

Any ideas how to diagnose and hopefully solve this? This is very annoying, and frankly there's not much I can do with Sony themselves, since "it works" when you're on the shop, and they've actually already exchanged it once...

I know I'm not giving you enough of the right information, these are all the things I can think about right now that I know about the problem. Please let me know what kind of info I should include.

Any pointers?

Thank you! Daniel

share|improve this question
    
Can you look at the router logs? What do they show with regard to connections/disconnections? –  soandos Jan 1 '12 at 17:48
add comment

2 Answers 2

Two things come to mind:

Uninstall SmartWI

The VAIO SmartWI product, in my opinion, is not a solid product and may be introducing the unreliability. I prefer to let Windows itself manage the wired and wireless network connections. That includes WiFi and Bluetooth.

Disable Power Save Polling on the VAIO

Power Save Polling (PSP) is used to place a wireless radio into a powered down state for brief periods of time. If there are mismatches between the client and the WAP, intermittent access problems can be had.

Disable PSP and place the VAIO into Continuous Aware Mode:

  1. Click the Start Menu and type "ncpa.cpl" (sans the quotes) into the search box and hit enter
  2. Right-click on your wireless adapter and select "properties"
  3. Click the button that says "Configure."
  4. Go to the Advanced tab.
  5. Select the Power Management property on the left side of the dialog box
    • Uncheck the option that says "Default / Auto" (or whatever verbiage is used to describe letting the driver determine power usage) and choose the option for "Highest / Maximum Performance" (or whatever verbiage is used to place the transceiver into an always-on state).
    • Some have said that if the slide is already at the highest setting for maximum performance, you shold move it down to the lowest setting, click "OK" and then go through the above steps again to move the slider to the highest setting.

Your other option is to tweak the PSP settings in the router itself, however that might be a bit advanced. If battery life isn't a big issue for your own devices on your home network, placing clients into a high performance setting will be fine.

share|improve this answer
    
Hi, thank you for your response, and sorry for the delay in mine. I tried, with the old laptop, installing a clean Windows, and the problem persisted, so it wasn't SmartWI. As for the PSP settings, I don't see that option. In the Advanced tab, I have "Dynamic MIMO Power Save" (which is disabled), and in the "Power Management" tab, I have "Allow the computer to turn off this device to save power", which is also disabled. I also don't see anything to tweak the "power settings" for the card. I also don't see anything related to PSP on my router :-( Any ideas? Thanks! –  Daniel Magliola Jan 6 '12 at 13:03
    
@DanielMagliola Sadly, it's going to be hard to do much more without seeing your exact settings. There could very well some pertinent option on the advanced tab of your wireless adapter's properties. It's just hard to tell what each vendor names each option. =| –  Wesley Jan 6 '12 at 16:59
add comment

There are many complaints of this kind on the Internet for Sony VAIO.

Some remedies that I found were :

  1. Set the router to broadcast the network name (SSID) (source)
  2. Verify that power output is 100% for the adapter (in Properties of the Atheros card, Advanced tab, select Power Output from the list) (source)
  3. Disable IEEE 802.1X authentication (in Properties, Authentication tab, uncheck Activate IEEE 802.1X authentication for this network) (source)
  4. Uninstall troublesome software : Boot in Safe mode and see if the problem disappears. If so, you will have to find the product that is responsible for the problem. This can be a security product or, as in here, Broadcom management.
  5. Use another wireless card. As yours is built-in, you might try a USB card.
share|improve this answer
    
Hi, thank you for your response! The router is already broadcasting the SSID. I don't have a "Power Output" option in the Device properties, nor anything like that. I also couldn't find the 802.1x auth option anywhere, could you give me more info as to where that may be (in Windows 7). As for software, I tried a clean install of Windows 7 (not the one that came with the laptop, a regular, clean one), and this also happened. Any other ideas? Thanks! –  Daniel Magliola Jan 6 '12 at 13:06
    
A clean install with drivers download from Sony covers most of my points. As Atheros gets many complaints, trying a usb wifi card might be useful. –  harrymc Jan 6 '12 at 13:25
    
Yeah, I want to avoid the external dongle. To be honest, if something as basic nowadays as Wi-Fi won't work, I think i'll return the damned thing for a refund and just buy something else. I just really didn't expect this from a Sony, they're not exactly the cheapest laptops on the market... Thank you for your help! –  Daniel Magliola Jan 6 '12 at 13:26
    
On my book Sony VAIO is to be avoided, seeing the number of posts I answer for it. It's good if you can still get a refund. My preferred mark is Dell, as being both good and relatively cheaper. Their support in europe is quite good, but I wouldn't know in the US. –  harrymc Jan 6 '12 at 15:59
    
Yeah. her previous laptop was a Dell, and it was REALLY crappy quality I also have a Dell, and love it, so it's kind of hit and miss I guess, and as far as I know, you needed to order them online, you didn't get to play around with them. I'll try to find some place that displays them, now that I'm in the UK. Thank you for your help! Looks like i'm getting a refund then –  Daniel Magliola Jan 7 '12 at 22:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.