Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I try to log into remote linux (ubuntu) machines from my MacBook Air (10.6), I get about a 4-5 second delay each time before I get promoted for the password. Verbose yields the following:

:~ ssh -v username@IPADDRESS

OpenSSH_5.2p1, OpenSSL 0.9.8r 8 Feb 2011
debug1: Reading configuration data /etc/ssh_config
debug1: Applying options for *
debug1: Connecting to 18.78.4.61 [18.78.4.61] port 22.
debug1: Connection established.
debug1: identity file /Users/Fabrice/.ssh/identity type -1
debug1: identity file /Users/Fabrice/.ssh/id_rsa type -1
debug1: identity file /Users/Fabrice/.ssh/id_dsa type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_5.8p1 Debian-1ubuntu3
debug1: match: OpenSSH_5.8p1 Debian-1ubuntu3 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_5.2
debug1: Unspecified GSS failure.  Minor code may provide more information
No credentials cache found

debug1: Unspecified GSS failure.  Minor code may provide more information
No credentials cache found

debug1: Unspecified GSS failure.  Minor code may provide more information

debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr hmac-md5 none
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host '18.78.4.61' is known and matches the RSA host key.
debug1: Found key in /Users/Fabrice/.ssh/known_hosts:6
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received

**------------------- 4-5 seconds Delay -----------------------**

debug1: Authentications that can continue: publickey,password
debug1: Next authentication method: publickey
debug1: Trying private key: /Users/Fabrice/.ssh/identity
debug1: Trying private key: /Users/Fabrice/.ssh/id_rsa
debug1: Trying private key: /Users/Fabrice/.ssh/id_dsa
debug1: Next authentication method: password

This seems odd to me - any ideas on how I could change that? I read something about DNS resolution being a possible culprit...

Thanks!

share|improve this question

migrated from stackoverflow.com Dec 28 '11 at 9:43

This question came from our site for professional and enthusiast programmers.

1 Answer 1

up vote 6 down vote accepted

This is a well known problem with Ubuntu. You have to disable a reverse DNS lookup on your Ubuntu server by setting UseDNS to no in /etc/ssh/sshd_config. There are tons of articles on this topic, this is just one of them.

share|improve this answer
    
Thanks! I had tried this but forgot to restart the ssh server with sudo /etc/init.d/ssh restart. –  nodapic Dec 27 '11 at 22:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.