Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I can't connect with Putty to a Linux box. In the putty log I only get 3 lines and the last line is "Server unexpectedly closed network connection". FTP and ping to the Linux box works. Putty is resolving host name either. Is there a special service I need to enable with putty and ssh? Ssh is working from a Linux client.

I get ssh_exchange_identifaction error. FTP is working though.

 ssh -vvv user@www.host.com
 OpenSSH_5.1p1  Debian-6.maemo5, OpenSSL 0.9.8n 24 Mar 2010
 debug1: Reading configuration data /etc/ssh/ssh_config
 debug1: Applying options for *
 debug2: ssh_connect: needpriv 0
 debug1: Connecting to www.host.com [99.99.999.999] port 22.
 debug1: Connection established.
 debug1: permanently_set_uid: 0/0
 debug1: identity file /root/.ssh/identity type -1
 debug1: identity file /root/.ssh/id_rsa type -1
 debug1: identity file /root/.ssh/id_dsa type -1
 ssh_exchange_identification: Connection closed by remote host
share|improve this question
    
try to delete your known hosts in ~/.ssh –  kobaltz Dec 28 '11 at 23:48
    
@kobaltz: I did. Folder .ssh is empty. It didn't want me to create a key? –  Phpdna Dec 28 '11 at 23:54
    
Related: Connection closed by remote host - Perhaps 'too many connections'? Have you checked the logs, and/or tried resetting the SSH daemon on the server? –  Ƭᴇcʜιᴇ007 Dec 29 '11 at 0:00
    
@techie007: ftp into server works but not ssh. Is is overload or an attack? What now? –  Phpdna Dec 29 '11 at 0:08
    
Ensure you're not logged into the server more than once, and/or ensure the SSH daemon/System is configured to allow you more than one concurrent connection, and as I asked/suggested before... Have you checked the logs, and/or tried resetting the SSH daemon on the server? :) –  Ƭᴇcʜιᴇ007 Dec 29 '11 at 0:12

4 Answers 4

Is there an /etc/hosts.allow or /etc/hosts.deny file that you have to work with? It's possible that it's not Putty at all and your WinPC is on the deny list or the Linux client that works is on the allow list.

share|improve this answer
    
It's the same box i.e. connection. I disabled some services but I don't know what service is important for putty and ssh? –  Phpdna Dec 28 '11 at 21:50
    
Can't help you there, sorry. Windows networking is a woeful (or not) gap in my education. –  Yitzchak Dec 28 '11 at 21:53

Sounds like you do not have OpenSSH-Server installed on the linux box. On debian base, do sudo apt-get install openssh-server and then retry the connection. Do you have a firewall enabled on the linux box?

How many failed login attempts did you make from this computer? I guess fail2ban is blocking that computer?

http://webcache.googleusercontent.com/search?q=cache:FeZUrSwcKqMJ:debianclusters.org/index.php/Fail2Ban:_Preventing_Brute_Force_SSH+&cd=1&hl=en&ct=clnk&gl=us&client=firefox-a

share|improve this answer
    
ssh is working from a Linux client. I remember it worked with Windows but I've disabled some services and I can't remember which one is important? –  Phpdna Dec 28 '11 at 21:41

Once you reboot the server, i can assure that the error will be gone.

Here is the useful link regarding this topic.

share|improve this answer
up vote 0 down vote accepted

It was denyhost that added me to the denylist. I could log into my server with little help from my isp and I have permanently added me to the hosts.allow list. But it can also be the ssh-key has not been properly deleted with rm -f ~/.ssh/known_hosts because after I use the alternate login method I get this error message:

@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
@    WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED!     @
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY!
Someone could be eavesdropping on you right now (man-in-the-middle attack)!
It is also possible that a host key has just been changed.
The fingerprint for the RSA key sent by the remote host is...

and I was forced to delete the key with ssh-keygen -R www.example.com-f /root/.ssh/known_hosts. rm -f ~/.ssh/known_hosts didn't work for me?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.