Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to mount an NFS share over a LAN:

  • Server: Arch Linux x64
  • Client: Windows 7 Ultimate x64

The server already successfully exports NFS shares to other Linux machines, so I'm pretty sure it has no problems. I added an entry in /etc/exports for the new Windows machine and restarted the nfs-server service.

On the Windows machine, I enabled the following in "Add/Remove Programs":

  • Services for NFS
  • Subsystem for UNIX-based Applications

Then, following the guide here I tried to run the following command to mount the NFS share so it would show up as the Z:\ drive:

mount //192.168.1.99/data/authorized Z:

I got the following output:

cmdlet New-PSDrive at command pipeline position 1
Supply values for the following parameters:
Root: 

It was waiting for me to enter something for "Root:". I'm guessing this means the NFS share root, so I entered it (/data/authorized), although it should've already been picked up from my initial command.

That's when I got this error:

New-PSDrive : Cannot find a provider with the name 'Z:'.
At line:1 char:6
+ mount <<<<  //192.168.1.99/ Z:
    + CategoryInfo          : ObjectNotFound: (z:String) [New-PSDrive], ProviderNotFou
    + FullyQualifiedErrorId : ProviderNotFound,Microsoft.PowerShell.Commands.NewPSDriv

How do I get the share to mount successfully?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

The mount you are running is the wrong one.

You are attempting to use mount in PowerShell, whereas the article is referring to the mount utility that is available from the regular Windows command-line interface (cmd), once you've added the NFS services/features to Windows 7 (Control Panel->Programs->Turn Windows features on or off->Services for NFS).

For comparison...

PowerShell Mount:

Mount in PS

CMD Mount:

NFS Mount in CMD

share|improve this answer
    
That was the problem. The final command I had to use was mount -o anon \\192.168.1.99\data\authorized Z:. The -o anon option was required, and only backslashes could be used for directory separation. –  srunni Dec 29 '11 at 16:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.