Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I bought a dual bay enclosure from NewEgg I'm guessing 2 years ago to set up a RAID1. It's now a discontinued model but it is from Sans Digital. I put two Western Digital 1tb drives in it. It's been working great for 2 years but before it suddenly disconnected. I got an error reading that the device had been unplugged and not properly ejected.. but it was still connected via USB. I tried it on my macbook pro and another macbook pro. I also tried other usb cables. I restarted/replugged/etc everything.. The enclosure turns on but nothing shows up on desktop or in Finder The blue lights which indicate the drives are on and in working condition come on and the fan runs..

When I run Disk Utility it appears - "1 tb External AL25744_12345678 Media" then a sub-line "BERNHARD" (which was the name I gave to my external raid hd)

Should two drives show up since I have 2 1tb drives in there? Or is this normal?

I do not know much about this stuff.

I am terrified to loose this - I am a photographer with years and years of work on these drives ... and I have no other backups. (I know - I am a fool)

My main question is - what do I do!? Do I buy a new enclosure and just pop them in? Also- Is it safe to unplug the drives?! Will I loose everything.. I took both of them out before when the power was off and things were unplugged - have I already ruined everything? I don't know how it works.

What would you do?!!? What can I do?! PLEASE HELP.

UPDATE -- JAN 4 2012 --

OK. So. I had a friend with an external docking station plug both drives into the same docking station. The bottom drive did not show up on his windows computer but the top drive did, but was still not accessible and could not be mounted. The enclosure's lights indicate that both drives are being read and are function. MacOSX disk utility "read" and "verify disk" say both drives are fine. My friend recommended I contact Western Digital about the drives I own because clearly this isn't the enclosures fault... the drives are just not reading/ non-accessible ..

What does one do from here? I'll be contacting WD tomorrow. But what would be the next step in retrieving my data?

share|improve this question
    
Can we get the exact model for the array? –  Mark Johnson Dec 29 '11 at 4:56
    
What filesystem are we dealing with? HPFS+? Or something else? –  Mark Johnson Dec 29 '11 at 4:58
    
Exact model for the array? How does one find this out? I am using a discontinued model of Sans Digital -dual bay enclosure - from memory I believe the model was called "TowerSTOR" or something.. which Sans Digital has revamped apparently.. ---- Also -- As far as what filesystems we are dealing with- I am ignorant to this.. is this a similar thing to journaling? I have it set for mac... or possibly both mac and pc "fat?" possibly.. Pardon my ignorance. THANK YOU SO MUCH FOR HELPING! –  rOB Dec 29 '11 at 5:46
    
Is the model number on the enclosure somewhere? Do you have the box it came in? How about the manual / documentation? If nothing else, it should be in your purchase history on Newegg. –  Mark Johnson Dec 31 '11 at 16:10
add comment

2 Answers

When you have two drives in RAID1 it will show up as a single drive because the computer is writing data to them synchronously, so you have redundant storage.

Now, if it told you it wasn't properly unmounted before disconnecting, but you can see your data, it's likely that you didn't lose much, if anything. The last thing you wrote to the disk, if you wrote anything in the recent past to them, could potentially be corrupted, but that's all I'd expect.

If you cannot see any data on the disks, I would first try doing a physical scan on the drive (Windows uses scandisk, I don't know what Mac has) and have it apply any repairs it can. This won't destroy any data that is intact, and should let you see it. If data is damaged, then you're probably out of luck without any other backups.

If the scandisk option doesn't help, it may be prudent to use data recovery software to try and retrieve the files off the drive. There's a lot of different software out there if you Google for it. Then after you're certain you've recovered your files, I'd do a full reformat of the drive.

share|improve this answer
    
I am not able to see any data on the disks... and by that I mean that it does not appear on my desktop nor in Apple's Finder (file browser)- Apple uses "Disk Utility" in which I ran (a very fast 1 min scan) overview that told me "appears to be OK" with no errors.. --As far as data recovery software -- do you or anyone else have recommendations for MAC OS X 10.6.8 ? I'll do my own research of course.. –  rOB Dec 29 '11 at 5:44
    
I've only had to use that kind of software once and it was a very specific use case, so the kind I got ended up being expensive. Recommendations on software purchases/downloads aren't really the goal of this site though so good luck on your research. –  Ben Richards Dec 29 '11 at 6:01
add comment

First off, stay calm, don't panic.

Since this is a RAID1 configuration, unless the filesystem is hosed or both drives are dead, you haven't lost any data.

Don't worry about removing the drives as long as you didn't swap them when you put them back in (or flip any switches on the enclosure).

Since Disk Utility can see the array, it sounds like the external enclosure is still working. Do you have any partitions listed in Disk Utility below the array? If so, can you mount them (Click on the partition, then click on the mount icon in the row of icons at the top of the Disk Utility Window)?

Don't do anything that would write to the array until you've figured out what is going on. At least not without imaging at least one of the drives first.

Something to keep in mind once you're back up and running: RAID is not a replacement for backups, it's a way to avoid downtime due to failed disks.

share|improve this answer
    
Thank you for your reply Mark - I was not able to mount the partitioned drive (BTW I am not 100% sure what this means... In disk utility it says "1 TB External AL25744_12345678 Media" with a sub-listing (indented below it/grayed out) it says the name which I assigned the drive "BERNHARD" -- So I clicked MOUNT and it was not able to mount, the pop-up menu recommended First Aid which came up "OK" -- the listing "1TB External AL25744_12345678 Media" I am not able to click the "MOUNT" button so I assume I am doing this correctly. -- ALSO -- How does one "image a drive" How does one do this? –  rOB Dec 29 '11 at 5:40
    
@rOB: In Disk Utility, if you select "1 TB External AL25744_12345678 Media" and click on the Partition tab (two to the right of First Aid), what do you see? –  Mark Johnson Dec 31 '11 at 16:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.