Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I had Ubuntu and Windows 7 installed, but since I never used Ubuntu and it used 130GB of space I decided to delete it. I deleted two partitions and completely wiped the one with the data. The other one - which I believe had the startup - wasn't wiped. By the way, my CD drive doesn't work.

At first I got "error: no such partition" in GRUB. Eventually I managed to put the Windows Recovery Disk on a USB stick and made it bootable using PowerISO. Windows Repair couldn't fix the problem automatically.

I then read some forums and asked somewhere else and they said to download GParted and put that on a USB stick, boot from it, and edit my partitions there. I downloaded GParted and tried to set it up the same exact way I got Windows Repair to work (with PowerISO), but it didn't work.

I formatted it as FAT, FAT32 and NTFS (but exFAT didn't work, that's the only one I haven't tried). I tried a program they recommended called Tuxboot, too, but that didn't work. I always got "error: no such partition". I've tried all the USB slots.

How can I recover the Windows 7 boot partition?

share|improve this question
1  
What you need to do is restore the MBR. –  Simon Sheehan Dec 29 '11 at 5:07
2  
Thank you sweet prince IT WORKED JESUS ALMIGHTY after eight hours. I googled that and followed these instructions: sevenforums.com/tutorials/… and they worked. Apparently I visited that link 5 hours ago too but closed it lol. Thank you! –  Jamie Dec 29 '11 at 5:29
1  
If no one puts the above comments in Answer form below I'm totally stealing it as per: meta.serverfault.com/a/1931/9770 =) –  Wesley Dec 29 '11 at 5:41
    
@Jamie, post the solution as an answer to this question! :) –  iglvzx Dec 29 '11 at 5:42
2  
@Jamie, you can post your solution as an answer. By doing so, we can upvote it and you can accept it (after two days) so that it no longer appears to be an unanswered question. –  DragonLord Dec 29 '11 at 5:43
add comment

3 Answers

up vote 4 down vote accepted

I managed to fix it by following the instructions at SevenForums.

So basically, if you have this problem, download PowerISO, format a USB drive, click Create Bootable USB drive, select the Windows Recovery Disc (you can download it online), boot from USB, click command prompt, and do what it says there.

For me, bootsect wasn't there, so I typed in Bootrec.exe /FixBoot and then Bootrec.exe /FixMbr like a link in that link says. Then I restarted my computer and it worked.

share|improve this answer
    
I had to do the same thing a little while back. It's a bit harder with XP, as that tends to not like being on a USB stick. –  Rob Jan 5 '12 at 16:12
add comment

I booted from recovery disc, then navigate to command prompt and enter: BootRec.exe /FixMbr

Was able to recoever the boot partition. Boot successfully.

share|improve this answer
add comment

Here's how i managed to do it. In my case the boot partition was unformatted and the bootrec gave an error saying it could not recognise the filesystem. howewer a simple format command from the recovery disk command prompt solved the issue . And i was successfully able to recover it! I have recorded the step here. Hope it helps http://murlidharshenoy.wordpress.com/2013/08/25/restoring-the-windows-boot-partition/

share|improve this answer
1  
Welcome to Super User! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Mokubai Aug 25 '13 at 9:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.