Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am currently running OS X 10.7.2 on a MacBook Air. As a quick note, while this program was installed through Steam, I don't think it's a Steam issue.

Background: Through Steam, I recently downloaded the Team Fortress 2 Beta to this Mac and then removed it via Steam's "Delete Local Game Content." This has left the "Team Fortress 2 Beta" icon stuck on the Launchpad, and I cannot remove it.

All of the typical methods for removing an icon have not worked (i.e., dragging to trash, Control+Option+Command+Left-Click, holding down left-click over the icon until icons start shaking, et cetera). I have uninstalled Steam (dragging icon in "Application" folder to trash) and removed all game content (deleted associated Steam directory in "Application Support") and that has not deleted the icon.

I have deleted the "Application Support" folder to try and force the Launchpad to reset itself; it did reset, but the icon remained there. There is also not an icon in the Application folder for the game. Clicking on the icon in the Launchpad does nothing, now that Steam is removed.

How do I remove this orphan icon from the Launchpad?

share|improve this question
Please do not crosspost the same question on multiple sites. If you don't get a satisfying answer on one site, you can flag your question for migration to a different site after a day or two. – Daniel Beck Dec 30 '11 at 18:34
up vote 9 down vote accepted

The same thing happened to me and I finally got it out of Launchpad and in the trash bin. You have to go to Finder > Go in the tool bar > Computer > Macintosh HD (or whatever hard drive you have) > Users > your username > applications and it should be there. For some reason this application folder is different then the standard and thats where mine was put. Hope this helps.

share|improve this answer
+1 this worked for me rather than @Razor's answer. Thanks. – therobyouknow Sep 7 '14 at 10:02

While in Launchpad hold down Ctrl+ then click on the icon you wish to delete until a question mark appears over the icon. Drag to the trash. Empty Trash.

share|improve this answer
This worked for me, but only after a reboot (on 10.9.1) – Hypermattt Feb 21 '14 at 18:38
Thanks @Razor but this did not work for me on Mavericks 10.9.4. What happened was that, while in Launcher, when I pressed: <kbd>Ctrl</kbd>+<kbd>⌥</kbd> all the icons wobbled. Some of them had a white x on a black circle on the corner of them. Others did not, including the one I wanted to remove. I clicked and held down the click on the one I wished to delete as you instructed but a question mark never showed, then all the icons stopped wobbling. I used Declan's answer below and that worked for me. I did not need to restart the machine. I would need to do this for each user on my mac though. – therobyouknow Sep 7 '14 at 10:10

Just search the game on spotlight (Once you've deleted it from Steam) and drag it to trash. Delete it from there and voila, the app's disappeared from launchpad.

share|improve this answer
This is an excellent solution as sometimes Launchpad apps are not actually located in the default Applications folder (Steam games for example) and some apps can't be dragged to the trash from Launchpad. Using Spotlight gets right to the source, great idea. – Andrew Feb 17 at 0:09

Had the same problem. Drag the icon from launchpad to the dock. Then right click the icon you just dragged to the dock and select show in finder. Delete the Icon in finder and then remove it from the dock. The icon should no longer be in launchpad.

share|improve this answer

Search for "Team Fortress 2" in Spotlight, hold down ⌃⌥⌘, and left click "Team Fortress 2" beside "Top Hit".

share|improve this answer

How about just holding control and left clicking (or right clicking) on the icon and saying "Remove from Dock"?

share|improve this answer
Unfortunately, no. Holding down control, command, option or any permutation thereof and then clicking either does nothing, or attempts to open the program. – Chance Dec 29 '11 at 21:14

You must log in to answer this question.

protected by Community Feb 19 '15 at 22:46

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .