Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am unable to do telnet on port 8000 while default telnet on port 23 works fine.

What configuration is required?

# telnet localhost 8000
Trying 127.0.0.1...
telnet: connect to address 127.0.0.1: Connection refused.

# telnet localhost
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
login:
share|improve this question
    
Is there a reason you need to use telnet? SSH is encrypted, and the preferred method. –  Jakub Dec 29 '11 at 22:18
    
I was just testing node.js connection event on telnet... –  P K Dec 29 '11 at 23:25
add comment

1 Answer

up vote 1 down vote accepted

It is possible that nothing is listening on the port 8000.
Try netstat -apn | grep 8000 to verify is anything listening.

share|improve this answer
    
yes i didn't get any output. –  P K Dec 29 '11 at 21:27
    
how to allow telnet on port other than 23? –  P K Dec 29 '11 at 21:27
    
To which program are you trying to telnet? That program should be set to use port 8000 –  bbaja42 Dec 29 '11 at 21:29
    
i am doing from the same machine 'localhost', i have a node.js program that is configured to listen on port 8000. do you mean i have to enable listening before telnet ? –  P K Dec 29 '11 at 21:31
    
It seems that node.js is not correctly configured to use port 8000. –  bbaja42 Dec 29 '11 at 21:32
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.