Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This is driving me nuts. I'm using Word to summarize books I study. Now, for a term such as


It first complains about why I don't have "Binding Operations". Then why I don't have "Clear Binding". And lastly, even after I add "BindingOperations" and "ClearBinding" to the dictionary, it complains aobut BindingOperations.ClearBinding!

My question is: How can I configure Word's spell checker to accept Word1Word2 and CorrectWord1.CorrectWord2 when the spelling of Word1, Word2, CorrectWord1 and CorrectWord2 are correct?

edit: I'm embarresed to say I have solved the problem. I just used dashes as in "Frame-Position" instead of FramePosition.

edit: Here's a skeleton for a word macro to solve this problem:

F8  twice (to select the word)
<control u> (to underline)
F8  twice (to extend selection to more than one word, because of a bug in Word 
    where replacing when just one word is selected replaces all across the document,
    not just across the selection )
<contrl h> (to replace)
<Alt i> (go get to the "Replace with" text box)
\1 \2
<Alt M> (for more)
<Alt U> (for wildcards)
<Alt A> (for Replace All)
<Alt N> (no replacement out of the selection)
<Alt U> (Reset the use wildcards)
share|improve this question
and what is your question? – Baarn Dec 29 '11 at 21:39
yea - the complaining is correct.. because it is grammatically correct. not technically correct. Unfortunately for this purpose you need to get a technical dictionary or some other kind of checker.. or mark technical terms to be ignored.. – ppumkin Dec 29 '11 at 21:40
Normally, camel case is incorrect. This is why the medical industry has their own dictionary. – surfasb Dec 30 '11 at 2:33
It's a shame that one of the answers is marked as the answer since it does not explain how to configure Office to see ThisAsCorrect but ThisAsIncorect, which would be dead useful when writing documentation for an API. – dumbledad Mar 11 at 10:51
@dumbledad You're correct, hence my edit. One possibility is to use Replace (Contol-H) and then Find What: "([a-z])([A-Z])" and Replace With: "\1-\2" with More/Use wildcards selected (of course, both the Find What and the Replace with without the double quotes. I also like to underline them so that they're easily recognized. – Avi Mar 11 at 12:40

2 Answers 2

up vote 3 down vote accepted

Spelling -> Set Proofing Language .. -> [X] Do not check spelling or grammar.

Set this for either a paragraph style you then use for blocks of source code or individually for blocks of source/text you don't want it to spell check.

share|improve this answer
Thanks. I'm aware of this and I'm using it for blocks of codes I copy (also use border so code samples are nicely marked). The problem, however, is that usually the explanations for the code then contain regular text paragraphs, where the camelCased words appear amidst rgular ones I do want to check. As no answer surfaced advising me how to do this, I'll accespt your answer. – Avi Dec 30 '11 at 14:31

I have the same issue; however I'm using MS Word to document Java Source code.

My solutions so far are to either:

  • Turn off Auto Complete for specific areas of text as mentioned above (not particularly good, as the grammatical style and auto-correction for the other words in the paragraph are useful).
  • Add the word to my local dictionary; again not perfect, as it means right click > add to dictionary whenever I write a variable, method or class name and repeat the process if i transfer the document to a different instance of word.

In each case, the word is camel case. Surely there must be a decent way to get ignore any camel case word in the auto-correct given the complexity of its other features, but I haven't found it.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.