Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I need FTP on my local LAN so my scanner can send me scans.

I am on Debian sid. I installed ftpd and created the user anonymous.
I removed anonymous from /etc/ftpusers

When I try to login as anonymous it says: login failed.

I can't seem to find any log file.

I'm using FTP server (Version 6.4/OpenBSD/Linux-ftpd-0.17)


update:I needed that so my printer had one place to store my scanned documents on the LAN. solved that buying a dedicated USB pen drive (thankfully I bought a printer one with plenty of options)

but in the past this was a very simple task. Install ftpd, specify the directory for anonymous access, and be done with it. now every ftp daemon has several layers of security and chroot in it's core... this is just crazy when all you need a place for a printer to dump files in a secured network.

share|improve this question
add comment

1 Answer

When using anonymous access, there is not associated system user account. From the manpage of ftpd.conf on Debian, it would appear that anonymous access is enabled by default. You simply need to specify in your FTP client that you wish to log in anonymously (again note that this is NOT the same as specifying "anonymous" as the username).

share|improve this answer
    
how's the proper way to log in as anonymous if not by logging in as anonymous in the username? –  gcb Jan 2 '12 at 1:45
1  
Depends on the client, but most have an "anonymous" login option. –  Garrett Jan 2 '12 at 4:37
    
ftpd.conf affects ftpd only, it's not available in debian-sid anymore, don't know why. trying the usual anonymous:a@ credentials on my client didn't work with the fpt daemons offered by debian-sid so i assume none of them have anonymous by default –  gcb Mar 19 '12 at 21:43
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.