Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This is really odd, because it shouldn't be happening at all.

When I access wellness.learnitlive.com on FireFox, I see it redirected to: http://www.learnitlive.com/classes-events/Health-Wellness/280.html

When I access wellness.learnitlive.com on IE/Chrome/Safari/Opera, I see it redirected to: http://www.learnitlive.com/wellness.php

Both are from the same machine. I'm not having FF use any proxy. Moreover, I see the same results on someone else's machine as well.

The /classes-events/Health-Wellness/280.html redirection was specified in the httpd.conf file yesterday, but is now set to /wellness.php and the httpd server has been restarted several times since the change.

I'm not sure why FF would be behaving like this.

I'm using OpenDNS and have refreshed their cache as well.

share|improve this question

2 Answers 2

up vote 3 down vote accepted

Firefox is caching this resource. Clean your browser cache: Firefox -> Options -> Privacy -> Clear your recent history -> Tick checkbox for "Cache" -> OK. Plain and simple.

For completeness, I'll also add that if you want to force a non-cached version of a page to be displayed, using Ctrl+F5 in most browsers will force one. In the case of redirect issues however (such as the one here), this won't help.

share|improve this answer
    
Interesting! And weird! Thanks gman - any thoughts on how I can 'break that'? –  siliconpi Dec 30 '11 at 6:42
    
I'm using mod_pagespeed on this server, but that didnt help in this case. –  siliconpi Dec 30 '11 at 6:57
1  
Browsers cache content for faster page load times. Clearing your cache when doing web development/deployment is just a part of life. –  Garrett Dec 30 '11 at 6:59
    
@SidB: It's not weird if the module is using 301 "Moved Permanently" type redirects; those are not only supposed to be cached, but the browser is even allowed to update bookmarks and links based on 301. If you want temporary redirects, switch to 302 "Found" or 307 "Moved Temporarily". –  grawity Dec 30 '11 at 16:15

You could change your cache settings so that it checks for a new version of the page every time for all websites.

  1. Type into the address bar: about:config.
  2. Click to confirm that you want to edit the settings.
  3. Search for browser.cache.check_doc_frequency.
  4. Double-click the line.
  5. Change the value from 3 (default) to 1.

For more details on this setting, see this link

share|improve this answer
    
Nice answer. thx for the link –  Mahes Aug 15 '12 at 20:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.