Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've been having a really annoying problem with explorer in Windows 7. Sometimes I need to restart explorer, for example to help testing software I'm developing.

I know I can stop explorer.exe (either through the task manager or through the Ctrl-Shift-Right Click on menu / Exit Explorer thing) and restart it through the task manager. That used to work just fine on XP. But on my Windows 7 box it just pops up a file browsing window. No taskbar, no start menu, no desktop.

Of course I can logout or restart to get the taskbar back, but that gets annoying really fast.

Any clues to what's going on here? Is something preventing explorer from restarting the taskbar? What's the mechanism used by explorer to determine whether it should do so?

[Update] I'm not looking for alternative ways to restart explorer. I found plenty of those while Googling for a solution to my problem. I need to know why explorer is not restoring my desktop icons and taskbar after it is restarted.

share|improve this question
Press > Windows + R and enter > explorer.exe – Daniel Dec 30 '11 at 11:49
No, that does not work. Windows + R only works when explorer is already running. – Marnix van Valen Dec 30 '11 at 13:15
Make sure all explorer.exe processes for your user are killed before you restart it – mavhc Dec 30 '11 at 13:38
Thanks, I tried that but it doesn't help. – Marnix van Valen Dec 30 '11 at 13:46
Did you end up finding a working solution? – Ivo Flipse Jul 15 '12 at 11:33
up vote 5 down vote accepted

Just had the same problem. It seems that when you run explorer.exe without full path it starts as C:\windows\explorer.exe /factory,{682159d9-c321-47ca-b3f1-30e36b2ec8b9} -Embedding, as you see, with parameters.

The solution I found, is to specify full path to C:\Windows\explorer.exe. This should run explorer without parameters. And starts Windows Taskbar.

And I really don't know, why such behaviour happens, cause before it worked fine without full path.

share|improve this answer
Thank you! works for me on windows 8 – Aminadav Jul 21 at 15:31

Press Ctrl + Shift + ESC. Go into Processes and stop Explorer.exe, as you already described. Then go to Applications --> New Task, type in explorer and press Enter.

That should work, if not try and go to Google. Search for explorer.exe and replace it. Good luck!

share|improve this answer
Do you have 64 or 32 bit? – Friend of Kim Dec 30 '11 at 14:04
Windows 7 Ultimate 64-bit – Marnix van Valen Dec 30 '11 at 14:08
  1. Press ctrl+shift+esc to open task manager
  2. Click new task and type regedit and press enter
  3. In registry editor, go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
  4. Beside the string value Shell the value data should be explorer.exe. Any value other than that can cause this error.
share|improve this answer

I had the same problem, and thanks to the answer by Jens Erat, I was able to find another solution! I've been repairing computers for years and have not seen this problem. Unfortunately, Jens' answer was not what did it for me, but while I was in that part of the registry, I saw a problem with the userinit key. The key had "c:\windows\system32\Userinit.exe."

The answer was to simply delete the extraneous period at the end of the path and start explorer again. Solved. Such a nice fix. I wonder how it ever got messed up in the first place. MalwareBytes did detect 50+ objects, however, which may have had something to do with it.

Anyways - a haiku for everyone to enjoy:

Yesterday it worked.
Today it is not working.
Windows is like that.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .