Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I searched some solutions, but rather old, don't seem to work with FF9.

Anybody knows a solution?

share|improve this question
    
have you tried wwww.website.domain:port ? –  Ramhound Dec 30 '11 at 15:04
    
yes, FF9 gave me two errors: - HTTP Error Status: 403 Forbidden; - Error Reason: Forbidden port –  hardywang Dec 30 '11 at 15:06
    
Sounds like a system configuration problem. You should be able to view a website, provided there is a website on that port, on any port you indicate. –  Ramhound Dec 30 '11 at 15:20
    
Do you connect through a proxy server? –  slhck Dec 30 '11 at 15:33
    
@slhck I tried in two environments, one with proxy one without, I got same problem here. The one with proxy is a system proxy all my browsers IE/FF/Chrome use it and only FF does not work. Update, I disabled proxy in FF and it worked!!! Don't understand why IE and Chrome use same proxy still work. –  hardywang Dec 30 '11 at 15:38
show 2 more comments

3 Answers

Firefox 9 will allow you to append :portnumber to any domain, for example:

www.domain.com:1234

The error you mention in your comment is nothing to do with firefox, but is sent from the server itself as it won't let you connect on the port you are trying.

share|improve this answer
1  
for example I visit server_host_name:81 in IE/Chrome and it works fine. But got forbidden port with FF9. –  hardywang Dec 30 '11 at 15:31
    
I wonder if the server may be configured to deliver dynamic pages based on the browser identifier - and this may be mis-configured for clients connecting using FF9. That error message is server generated. –  Rory Alsop Dec 30 '11 at 15:35
    
Sounds like proxy, I have IE/Chrome/FF use same system proxy but only FF does not like it other two just work fine. –  hardywang Dec 30 '11 at 15:43
add comment

Just add in about:config page a new value called

network.security.ports.banned.override

and list the ports that you want to disable blocking on.

This works for FF12 and FF13 but I presume that it will solve your problem.

share|improve this answer
    
This is the correct answer. –  DragonLord Jul 25 '12 at 0:32
add comment

Usually that means you need to portforward, as far as I'm aware, I used to host game servers, and the firewall installed on the router blocks access to certain ports (incoming and outgoing), there are instructions on how to unblock ports from a huge array of routers here.

If you don't have a router, then you might need to call your ISP to unblock ports for you :)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.