Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to compile gwibber. This is what happens when I type ./configure.

checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking for valac-0.14... no
configure: WARNING: No Vala compiler found.  You will not be able to compile .vala source files.
configure: error: "No valac compiler found."

But this is what I get when I type valac --version

Vala 0.15.0

So, I do have the right version of valac, right? How can this be fixed?

share|improve this question

1 Answer 1

Install libvala-dev? Depending on your distribution, your command may be different, but in my case it would be on Ubuntu:

sudo apt-get install libvala-0.12-dev

enter image description here

If you are on Debian based linux then just do

sudo apt-cache search libvala

or

sudo apt-get install libvala-dev

and it will usually download the latest version.

enter image description here

share|improve this answer
    
I tried apt-get install libvala-dev and it said itw as already at the newest version. Then I tried apt-get install libvala-0.12-dev and it installed something but didn't have any affect. –  tony_sid Dec 31 '11 at 7:27
    
It looks like you're needing an older version. You have 0.15 installed but it's looking for version 0.14. –  kobaltz Dec 31 '11 at 7:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.