Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I need to run Firefox each time in a new profile directory with my extension enabled. What I do is the following:

  • Create temporary directory for storing profile (/tmp/profile.123)
  • Create extensions directory (/tmp/profile.123/extensions)
  • Create extension proxy as described here (/tmp/profile.123/extensions/myextension@my.domain)

My command line looks like this:

firefox -no-remote -profile /tmp/profile.123 -url http://www.google.com

The problem is that my extension starts disabled, and I'm forced to enable it manually and restart the Firefox. Is it possible to make it start enabled in first place?

Thanks!

Workaround I've found:

Create extensions.sqlite database file in the newly created profile folder. This file must contain my extension entry under the "addon" table.

share|improve this question

1 Answer 1

No way to check it now for sure, but probably you have to play with extensions.enabledAddons (and/or extensions.enabledItems) in prefs.js file in the profile folder.

Something like:

user_pref("extensions.enabledAddons", "extId1:version,extId2:version");

share|improve this answer
    
Already tried this, but it doesn't work. –  spektom Jan 1 '12 at 4:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.