Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've installed a server at home to have as a fileserver due to limitation of an iMac and USB-ports (too many external harddrives is a pain in the ass). I'm using both Samba and Proftpd to manage files from it.

I can upload files to the server (over both smb and ftp in ~100MB/s) whilst when I'm trying to download stuff from the server it only tops around ~2MB/s at best. This is quite tiresome when I want to stream 1080p movies and other stuff from it.

ethtool says its on full duplex and 1000MB/S speed

neme@chidori:~$ ethtool eth0
Settings for eth0:
Supported ports: [ TP MII ]
Supported link modes:   10baseT/Half 10baseT/Full 
                        100baseT/Half 100baseT/Full 
                        1000baseT/Half 1000baseT/Full 
Supports auto-negotiation: Yes
Advertised link modes:  1000baseT/Full 
Advertised pause frame use: Symmetric Receive-only
Advertised auto-negotiation: Yes
Link partner advertised link modes:  10baseT/Half 10baseT/Full 
                                     100baseT/Half 100baseT/Full 
                                     1000baseT/Full 
Link partner advertised pause frame use: Symmetric Receive-only
Link partner advertised auto-negotiation: Yes
Speed: 1000Mb/s
Duplex: Full
Port: MII
PHYAD: 0
Transceiver: internal
Auto-negotiation: on

And I've even tried to manually enable full duplex on my Mac just to be certain, and the problem still is there. Even tried on two other MacBook Pro's

The server is running Ubuntu Server 11.10

Anyone have any ideas? Cheers

Update

Solved: Seems like the problem was the PCI-E Networkcard. Changed to the built-in card and now I get speed from 50-80MB/s depending on which harddrive.

Maybe "LAN TPO 1000Mbps PCIe Gigabit 10/100/1000 Realtek" is just bad or mine is just bonkers? Anyone now how good this card really is? I guess that you get what you pay for. Next time I'll add a couple of $$$ and get a nice Intel one.

share|improve this question

migrated from stackoverflow.com Dec 31 '11 at 22:41

This question came from our site for professional and enthusiast programmers.

    
How fast can you read the files on the server itself? I had a drive in a RAID array that was going bad, and it resulted in abysmal read speeds. –  Darth Android Dec 31 '11 at 23:20
    
Well, its the same from all the discs, old and new, @DarthAndroid /dev/sdb: Timing buffered disk reads: 306 MB in 3.00 seconds = 101.87 MB/sec /dev/sda: Timing buffered disk reads: 196 MB in 3.00 seconds = 65.26 MB/sec /dev/sdc: Timing buffered disk reads: 318 MB in 3.01 seconds = 105.66 MB/sec /dev/sdd: Timing buffered disk reads: 234 MB in 3.02 seconds = 77.41 MB/sec –  neme Jan 1 '12 at 13:13
    
Alright, those look fine :) I was having similar issues, but it was because one of my disks was giving me about 200KB/sec. What about the filesystem itself? Try testing the raid device, or creating a 1GB file on the filesystem and then reading it locally with dd into /dev/null and see what speed that takes. –  Darth Android Jan 1 '12 at 16:34
    
Seems like the real problem was one of my networkcard, maybe it's bonkers? I have one build in and one PCI-E, used the PCI-E before and now I changed to the build in one and everything works as expected. –  neme Jan 1 '12 at 17:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.