Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Received a "folder access denied" warning after wanting to delete a folder so I needed to change permissions on a folder. Changed it to - for example: "username (username-PC\username)". That was the "username" I was currently logged in as but strangely received the same exact "folder access denied" even though I had "permissions" on that folder.

share|improve this question
2  
Some of these folders and files dont exist in that location, they are just links. Changing the permission doesnt do anything, and can actually cause very deep problems sometimes. Finding out where they actually put the stuff is probably what you need. –  Psycogeek Jan 1 '12 at 7:07
    
Very interesting. I should look into that. It's more curiosity that's driven me to look into this. It's not like I'm starving for disc space or anything. I did get some warnings about ?file inconsistency? while trying to change permissions. –  Christopher Chipps Jan 10 '12 at 6:58
    
I was just trying to toss up a lite warning. I dont have a handle on it myself. but I can screw up the system with an infinate loop :-) –  Psycogeek Jan 10 '12 at 7:01
    
I've seen problems like this when the file system is corrupted. It might be worth trying a file system check/repair, but make sure you have a good backup first. The repair operation can sometimes turn a mostly-working file system into a not-working-at-all file system, particularly if there is an underlying hardware problem. –  Harry Johnston Jan 11 '12 at 1:46
    
It could also be due to a rootkit, or your antivirus software might be locking the folder for some reason. –  Harry Johnston Jan 11 '12 at 1:47

2 Answers 2

up vote 3 down vote accepted

It can be some application that has a lock on the folder. Download and install Unlocker Right click on the folder and click the unlocker menu item. There is a delete file option on the main screen.

Else you can use SysInternals Process Explorer to see which application has locked the folder.

EDIT: I recently came to know that Unlocker sometimes does not detect locks on folders by applications. Instead try runs the commandline tool Handles from SysInternals. This tool will also allow you to closing an open handle. (Caution: Closing an open handle MAY cause a system crash in some cases.)

share|improve this answer
    
Thanks for the recommendation. I downloaded Unlocker and tried deleting the file but it gave me the message that "it can't be deleted but try again at next reboot". So I agree but have yet to reboot. –  Christopher Chipps Jan 10 '12 at 6:50
    
While reading your answer in addition to the above comments, it seems like I would do more harm than good in trying to get rid of this program (MS Internet Explorer). I use another browser and just wanted to free up space but I guess I'll deal with the fact that I've tried many things yet have been unable to delete the folder. If the folder was malicious or detrimental to my system, I would try harder to get rid of it but it seems that I may hurt my system in trying to do away with the folder so I'll allow taking up some space. –  Christopher Chipps Jan 15 '12 at 21:21
    
@ChristopherChipps Can you mention the folder name (check on google if its a system folder) and try handles to see if it can help you out here? Also if you just want to empty the folder, can you try deleting its contents instead of delete the whole folder? –  Ganesh R. Jan 16 '12 at 9:11

You say you took ownership of the folder; did you also change the permissions? Being the owner does not in and of itself allow access to a file or folder, although it does allow you to read and set the permissions.

(Note that under some but not all circumstances the GUI will change permissions automatically when you take ownership of a file/folder.)

share|improve this answer
    
I took ownership and changed the permissions. Interestingly enough, while trying the above comment's suggestion and finding no "Deny permissions", I gave the user "Full Control" permissions which seems to cause some havoc. It gave some sort of warning about file inconsistency or something or other. After clicking ok, it gave me the option to delete file (finally!) but after clicking "ok" it sent me back that I needed permissions from the user who is me. –  Christopher Chipps Jan 10 '12 at 6:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.