Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a flash drive which is given as a freebie. I don't know who manufactured it. It got infected by a virus. I am trying to reformat it but I am always receiving a "Windows was unable to complete the format" message. When I checked its properties, the used space and free space is 0 bytes. On disk management, it says that the flash drive has raw file system with 8mb capacity. The status of the flash drive is "Healthy (Primary Partition)". However, the real capacity of the flash disk is 1gb.

How can I recover the missing space? I tried using diskpart to clean and delete the 8gb partition, then create a new partition hoping that it will fix the problem but to no avail. Until now, I also can't reformat the flash disk. I also tried using BootIce and Active KillDisk, but it also didn't fix the problem. On the other hand, SpaceSniper claims that the location of my flash drive is not a valid path. I also tried using Lexar but the drive letter of my usb won't even appear on its list. Meanwhile, HDD Low Level Format Tool says that my device cannot be accessed because it is smaller than 65535 sectors.

I am already out of options. How can I fix my flash disk? How can I format it and reclaim the missing space? (I am using Windows 7.)

The following are displayed when I used KillDisk:

Name: Generic Flash Disk 2.0

Version: 2.10

Mode LBA: Yes

Cylinders: 1

Tracks per Cylinder: 255

Sectors per Track: 63

Total Sectors: 16384

Bytes per Sector: 512

Total Size: 8.000 MB (8388608 bytes)

(What happened to the other space? Why only 8 bytes can be seen?)

share|improve this question
    
I have heard of: A flash drive/card that has been Hacked by sleezy sellers to indicate the wrong size, so they can sell the item for more than it is worth. They work fine as long as you do not fill them, once they reach the point of No-Nand actually there, they corrupt and show as 0 and will not format. A site called ChinaMP3 was very adept at discovering this on many e-bay sold mp3 players, and they actually Firmware fixed some. Again, everything is fine untill they reach the end of real. so some people didnt know for months. But this is still showing its disk info, so I dont know. –  Psycogeek Jan 1 '12 at 14:55
    
here is a link, to show the prevelence duckduckgo.com/?q=fake+Flash+cards&t=i With a Windows system, a person might try using the Chkdisk with the R option. superuser.com/questions/192583/repair-flash-disk –  Psycogeek Jan 1 '12 at 15:35
1  
Try this tool for UT165 -- if your flash device is supported, you can find out and fix the actual size, bad cluster count, etc. –  grawity Jan 2 '12 at 8:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.