Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a computer which is plugged directly in the net via the ADSL modem provided by the ISP.

Sometimes there is need to connect other computers on the net. Then I add a TP-LINK wireless router to the sytem, so that the wireless router is plugged into the ADSL modem and the mentioned computer is plugged with a cable into one of the ports of the wireless router and other computers connect wirelessly.

The problem is when the wireless router is connected then the net is much slower. When the computer is plugged into the ADSL modem directly then it has 2 MBps download speed, but if it is plugged into the wireless router then the download speed is only 0.7 MBps.

Why is that? It's not the problem of the wireless connection, because the main computer is plugged directly into a port of the wireless router, so it has direct cable connection (computer - wireless router - adsl modem). I'd understand it if it were a wireless connection, but it is a cable connection, so there couldn't be a collision in the radio frequency. BTW, the net is slow even if only the main computer is connected to the wireless router, so it's not about the other computers connected wirelessly taking up extra bandwidth.

share|improve this question
You may want to check and make sure that your router is not set in 802.11b mode as it sounds like that is the speed that you're getting. – kobaltz Jan 1 '12 at 10:17
I'll check when I'm near that computer, but I don't see how that could be the reason of the speed I'm getting. "802.11b has a maximum raw data rate of 11 Mbit/s" according to Wikipedia, so surely even with this setting I should have get more speed with a direct cable connection than 0.7Mbit/s – Tom Jan 1 '12 at 11:08
802.11b has max raw data rate of 11 Mbit/s, which is about 1.4 MBps. But that is maximum data rate. explains how average data speed is usually much less, about 2-3 Mbit/s. – bbaja42 Jan 1 '12 at 11:56

Your router is probably doing NAT to allow your machines to share a single public IP address. This means it's rewriting the headers of every single packet it passes in either direction. If its NAT code is inefficient or its processor is underpowered (as is common in cheap no-name home networking gear), then that's where your performance is going.

You may be able to test this theory by disabling NAT and DHCP service on your wireless router so it's just a bridge. If it doesn't allow you to disable NAT, then just disable the DHCP service and stop using the WAN port. Plug one LAN port of the TP-Link into the DSL modem, and another LAN port into your computer. Configure your computer as if it was directly connected to the DSL modem and see how it performs in this case. This way its traffic is going through the TP-Link device but not getting hit by its NAT code.

share|improve this answer
stop using WAN port works perfectly – laplasz Jan 11 '14 at 19:46

You could potentially be receiving slower speeds due to the speed and duplex settings on the wan port of the router. When you log into the administrative web interface check to see if you can manually specify those particular settings. Try to lock down the interface to speed 100 and full duplex first and then test your speeds again. If you are still not satisfied with the speeds experiment with other speed and duplex settings until you find one that works best.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .