Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

As the title indicates, I am unable to connect more than 1 computer to the same network.

Scenario: I own a Toshiba Satellite A660-11M which has a built-in Broadcom 802.11n adapter. I am using a Wireless-N 300Mbps Access Point, specifically this one. I followed the manual on setting it up, and it is currently running at most of its default-settings:

  • Static IP
  • Working mode: Access Point
  • Security: WPA-PSK/WPA2-PSK
  • Channel Width: Auto
  • "Frequency Band": 20/40MHz

Issue: This time, my issue is merely related to the fact that no other computer but mine (or presumably any computer that enters the network first), can access the internet via that Access Point (which is hooked to a cable modem).

I would just like to know if there is a solution to this; maybe I am missing a setting, or maybe I have enabled something that causes this.

Thank you again very much!


  • I tried connecting the second computer to the network in the most usual way: The OS finds the network, you double-click it to connect and type the password. The second computer did manage to access the network, but remained unable to access the internet (i.e. network without internet connectivity). When trying to load a website in Chrome, (I think) the result was a timeout - I do not quite recall what the message was, but it was not a standard "you don't have internet, please connect to the internet" message.
  • The second computer was the exact same model, with the exact same technical specifications as my computer (i.e. Toshiba Satellite A660-11M).
  • I have no setup any security options, so I do not think there is any MAC-address filtering unless such features get enabled by default. I have only setup a WPA2-Personal password.
share|improve this question
This question requires more detail. What is your process you have attempted in trying to join another computer to your wireless access point? What is the hardware specification of a system that you have attempted to joining to your wireless network and failed to do so? Do you have any type of secondary parameters in your security topology on the router in place (i.e. MAC address filtering)? – Mort Jan 1 '12 at 16:26
My bad, updated the question. – cr0z3r Jan 1 '12 at 16:53
I could only guess, and you could test. Switch it from access point to "Point to Multipoint", and turn off static and switch on the DHCP server. seems it is capable of working many different ways, for different purposes. – Psycogeek Jan 1 '12 at 17:04
@Psycogeek I am afraid that turning the Static IP option off, would make it impossible for me to access the AP's config-site afterwards. Is this normal - or am doing something wrong? – cr0z3r Jan 1 '12 at 17:09
sorry I dont even know words like "accesspoint" and "adhoc" Your trying to connect many computers to a wireless, the device needs to feed them some sort of IP to connect, DHCP can hand out addresses to computers asking to connect. or you properly set up all static addresses?? you still need an expert to help here. – Psycogeek Jan 1 '12 at 17:43
up vote 2 down vote accepted

You need a router or multiple IP addresses from the ISP to have more than one device connected using your setup. Your ISP is only giving you one IP address. Your access point is not routing and giving you a private IP address which would allow you to have multiple PC's (or devices) connected and routed to the internet.

share|improve this answer
I know that my ISP provides me with dynamic IP addresses; and I also recall that in my AP configuration, I left the "Static IPs" checked because I was unable to access it via its Default Gateway otherwise (to keep configuring things). Would this be the solution? I am unsure as to what you're suggesting I should do. Thank you! – cr0z3r Jan 1 '12 at 17:06
our Cable type ISP here, does not care how many computers in the one home are using the connection. Only if I start feeding the neighborhood would they have a problem. All computers though do so via the same "External" or "net" IP address. To have more than one actual external net address at a time, costs about $5 each. – Psycogeek Jan 1 '12 at 18:52
the use of a router that assigns private IP addresses would allow you to use as many devices as you would like with no additional fees – Mark S. Jan 1 '12 at 19:23
No need to get more than IP address from the ISP. 99% of ISP customers use just one IP address and an on-site router. The router would provide DHCP, NAT, firewall et cetera functionality for local PCs. Right now your PC is exposed to the Internet, and probably "protected" solely by the weak MS software firewall. – sawdust Jan 1 '12 at 22:57
@cr0z3r - re "what should I do?!" Mark Scrano has already answered this question, you need a (wireless) router. WPA2 is only part of wireless security. Your PC is still totally vulnerable to probes and attacks coming through your ISP connection. If your PC can connect to the Internet and World Wide Web, then without the protection of a router, hackers on the Internet can connect to your PC. Wireless security and AVG software are not substitutes for NAT and a firewall. – sawdust Jan 2 '12 at 23:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .