Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My macbook does not want to go to sleep when I close the lid or manually choose sleep from the apple menu.

Things I have tried:

  • resetting the PRAM
  • resetting the SMC

According to PMSET the following assertion did occur:

   PreventSystemSleep                      1

No idea why or where that comes from.

Edit: Apparently cupsd is the problem, but why is it acting up all of the sudden? I haven't changed any of my printer settings lately.

share|improve this question
take a look at this:… Also, some process could be writing to the disk to prevent sleeping. I had this issue, and could not figure out which process was the culprit, but a restart solved the problem. (not really a solution I know) – lhagemann Jan 1 '12 at 15:26
Related. – Daniel Beck Jan 1 '12 at 15:56
Related. – Daniel Beck Jan 1 '12 at 15:59

Because printers make requests that prevent your computer from sleeping.

These requests can persist until you uninstall the printer. I had this happen to me for about six months and had no clue at all what it was, but the command (in terminal)

pmset -g assertions

… showed it was a printer request keeping my computer awake.

share|improve this answer
wouldn't purging the print queue help without having to uninstall and install printers? Assuming that there were unfinished print jobs and that's why there were such requests. – lupincho Apr 10 '12 at 14:15
up vote 0 down vote accepted

Remove all printers added, re-add them.

share|improve this answer
Any chance of an explanation as to why this would fix the problem? – Mokubai Jan 2 '12 at 10:28

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.