Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm getting a blue screen "A clock interrupt was not received on a secondary processor within the allocated time interval", just a few seconds after the Windows desktop is loaded. (For reference, this is BugCheck 0x101: CLOCK_WATCHDOG_TIMEOUT.)

  • My CPU is a Core i7 Extreme 975 and the BIOS is up to date.
  • My motherboard is a Gigabyte EX58-UD5.
  • My OS is Windows Server 2008 R2 (which I'm using as a Workstation).

For the moment, I disabled one core (out of four) on the BIOS settings and my computer is working well. But I would like to use all the cores available in my CPU, with Windows.

I think it is not related to an hardware problem, because Ubuntu (Live CD) is working on my computer with all cores enabled.

I'm NOT using Hyper-V or any other roles.

share|improve this question
    
Did this EVER work? You mention your BIOS twice, but what kind of motherboard? –  Ƭᴇcʜιᴇ007 Jan 1 '12 at 22:23
    
I'm always getting a BSOD. My motherboard is a Gigabyte EX58-UD5. –  anonymous Jan 1 '12 at 23:31
2  
Has Windows ever worked? Is this a new install or an old install that has suddenly broken? –  Mokubai Jan 2 '12 at 0:33
    
Windows works only with 3 cores. It always crashes with 4 cores. It is a new install. Before I updated my BIOS, Windows (with all the 4 cores enabled) was crashing before loading the desktop. –  anonymous Jan 2 '12 at 1:17
    
Hardware problems sometimes only exhibit for particular operating systems. Can you select which core is disabled? –  Harry Johnston Jan 2 '12 at 1:48

1 Answer 1

You have a "Nehalem" microarchitecture Intel CPU, you have Windows Server 2008 R2, and you haven't installed the hotfix.

Further reading

Microsoft blames Intel.

Intel blames Microsoft.

Always check the doco provided by the manufacturer before coming to SuperUser.

share|improve this answer
    
The Hyper-V role is not installed by default. Anonymous, did you install Hyper-V? –  Harry Johnston Jan 3 '12 at 1:22
    
The second MS link above says this in the workaround section: "You can disable the Advance Configuration and Power Interface (ACPI) C-states by using a BIOS firmware option on the computer. If the firmware does not include this option, a software workaround is available. You can disable the ACPI C2-state and C3-state by setting a registry key." Though everything is in the context of hyper-v, this appears to be a ACPI power save issue (?) –  horatio Jan 4 '12 at 16:40
    
Also this linux bug listing might be old news, but possibly relevant: "This bug has not been visible until Nehalem, which advertises a CPU-C2 worst case exit latency on servers of 205usec. That (incorrect) figure is being used by BIOS writers on mobile Nehalem systems for the AC configuration. Thus, Linux ignores C2 leaving just C1, which is saves less power, and also impacts performance by preventing the use of turbo mode." ( see: bugs.launchpad.net/ubuntu/+source/linux/+bug/516325 ) –  horatio Jan 4 '12 at 16:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.