Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

For some reason I can't open Catalyst with administrative privileges on Xubuntu 11.10. The regular Catalyst Control Center works fine, but it doesn't allow me to make necessary changes to my multiple monitor configuration. Is there a way to open it through the terminal with a sudo command, or is there anything else I should be looking for?

I used the command the following command to open Catalyst with admin privileges:

sudo amdcccle

It automatically configured my multiple monitors and placed one on top of the other, instead of side by side. It won't allow me to make any changes. Every time I try to hit the apply button, it closes without making any changes.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

I'm running Xubuntu 11.10, and I worked around the issue in the following way:

1) Installed Unity

sudo apt-get install ubuntu-desktop

2) Swapped over to Unity, configured my monitors and applied the settings.

3) Reboot from Unity (don't log out), then log in using a Xubuntu/XFCE session after reboot.

I had to do this step twice before it stuck for XFCE. Not quite sure why, but I'm wary of fiddling with it any further.

4) Removed Unity (optional)

sudo apt-get purge ubuntu-desktop

sudo apt-get autoremove

If anyone knows a more reliable approach to step three, I'd love to hear it.

share|improve this answer
    
That almost worked. Unfortunately, I just couldn't get the required resolution, even under Unity. I'll accept you answer, because it might work for others. I fixed the issue by switching to Mint. –  Arthur Jan 2 '12 at 20:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.