Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I downloaded ez_Setup.py from here.

I have python 2.6 on CentOS 6.

When I do this:

python ez_setup.py

I keep getting this error:

Downloading http://cheeseshop.python.org/packages/2.6/s/setuptools/setuptools-0.6a8-py2.6.egg
Traceback (most recent call last):
  File "ez_setup.py", line 214, in <module>
    main(sys.argv[1:])
  File "ez_setup.py", line 147, in main
    egg = download_setuptools(version, to_dir=tmpdir, delay=0)
  File "ez_setup.py", line 128, in download_setuptools
    src = urllib2.urlopen(url)
  File "/usr/lib/python2.6/urllib2.py", line 126, in urlopen
    return _opener.open(url, data, timeout)
  File "/usr/lib/python2.6/urllib2.py", line 397, in open
    response = meth(req, response)
  File "/usr/lib/python2.6/urllib2.py", line 510, in http_response
    'http', request, response, code, msg, hdrs)
  File "/usr/lib/python2.6/urllib2.py", line 429, in error
    result = self._call_chain(*args)
  File "/usr/lib/python2.6/urllib2.py", line 369, in _call_chain
    result = func(*args)
  File "/usr/lib/python2.6/urllib2.py", line 616, in http_error_302
    return self.parent.open(new, timeout=req.timeout)
  File "/usr/lib/python2.6/urllib2.py", line 397, in open
    response = meth(req, response)
  File "/usr/lib/python2.6/urllib2.py", line 510, in http_response
    'http', request, response, code, msg, hdrs)
  File "/usr/lib/python2.6/urllib2.py", line 435, in error
    return self._call_chain(*args)
  File "/usr/lib/python2.6/urllib2.py", line 369, in _call_chain
    result = func(*args)
  File "/usr/lib/python2.6/urllib2.py", line 518, in http_error_default
    raise HTTPError(req.get_full_url(), code, msg, hdrs, fp)
urllib2.HTTPError: HTTP Error 404: Not Found
share|improve this question

1 Answer 1

up vote 0 down vote accepted

I've got the same error when trying to access to http://cheeseshop.python.org/packages/2.6/s/setuptools/setuptools-0.6a8-py2.6.egg, the file doesn't exists. But, there are

setuptools-0.6c11-py2.6.egg
setuptools-0.6c10-py2.6.egg
setuptools-0.6c9-py2.6.egg

that are available, so if you manually download and install the last one (setuptools-0.6c11-py2.6.egg) it will work.

The other problem I noticed, is that the ez_setup.py script I downloaded from the url you gave (and it is perfectly working by downloading the correct setuptools-0.6c11-py2.6.egg) doesn't correspond with the error lines you gave in your question, maybe the script you have is an old version, just re-download it and try to relaunch it.

share|improve this answer
    
Thanks , i will try this as soon as i get home. –  kritya Jan 2 '12 at 12:17
    
Thanks it worked :D –  kritya Jan 3 '12 at 4:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.