Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

We have an HP Compaq dc7900 in the office. 4 days ago it had several problems in the USB connection; that we couldn't connect anything via any USB port (tried a scanner and a walkman). We left the problem unsolved (and undiagnosed) and went to vacation, and when returned today, and when attempted to power it on, the PC starts booting and before it gets anywhere it just freezes (effectively hangs if I may say so), with the screen showing the following text:

HP Compaq dc7900 Convertible Minitower
v01.16
<F9=Boot Menu> <F10=Setup> <F12=Network>

The keyboard at this point isn't responding. When rebooting (a hard reboot) the same thing happens over and over, but I notice that the keyboad responds within the first few seconds after that screen of hang appears (2 or 3 seconds) and pressing F9 or F10 triggers the option but leads nowhere (still hangs). I've been able to take the hard disk and back it up somewhere else, but regarding the PC I have no idea or a clue to start with, as I can't think of a cause of the problem.

What can be this problem? And what steps can I take to further diagnose and resolve the problem? Any guidelines and direction of research are thankfully welcomed...

EDIT: I'd like to apologize to those who answered and/or reviewed this question. I was not able to follow up and update the question as my company took the CPU to the repair shop and the repair shop took it to another one that is unreachable to me. The last person I could follow up with said that he suspects the problem to be a hardware problem, exactly in the I/O chip on the motherboard, but with no further details. I will follow up whenever I could find any more details or when the repair shop returns the CPU (if it was not replaced). I hereby want to say sorry for every contributor in this post, and for the community for not completing and following up with the question. Thank you all.

share|improve this question

closed as too localized by techie007, Brad Patton, slhck May 19 '13 at 21:50

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
This sounds like silent boot is enabled, please have a look at your BIOS and disable silent boot if possible. If that works, the initial bootscreen may provide additional information about what the computer does while it 'hangs'. –  Michael K Jan 2 '12 at 13:44
add comment

3 Answers

Some things I'd try in this order:

  • remove the CD from the tray (if there's one in it :-)

  • remove any usb stick plugged in

  • remove the power cord, open the case, dangle connectors to drives, re-insert memory sticks and adapters

Is the keyboard a usb one? Can you plug in a ps/2 one too?

share|improve this answer
    
Did all the above. Nothing changed. What are you suspecting of? –  amyassin Jan 2 '12 at 13:03
1  
It helps me sometimes to get the system working again. Have you changed something in the bios before the vacation when trying to get the usb working? Some HP PCs can go to repair/recover menu by pressing F4 when powering on. –  ott-- Jan 2 '12 at 14:25
add comment

Just had the same problem, solution for me was to unplug all USB devices and than by plugging one by one determined that my external USB Logitech Speaker is causing the problem.

No problems coming from sleep mode, only restart and shutdown...so I unplug USB Speaker , then boot to Windows, then re-plug it back. Maybe a new BIOS update can solve the issue but didn't try.

share|improve this answer
    
Actually I didn't check with them. Thank you for reminding me.. I'll follow up soon.. –  amyassin Aug 7 '12 at 6:29
    
Its not that bad in my case so didnt want to mess with BIOS but some guys have problems with camera or external HDD ,keyboards...talk to u later –  Mike Aug 7 '12 at 15:09
add comment

You can upgrade your BIOS from this link.

It's a latest version and I'm sure your problem will be solved. Remember one thing: during the upgrade don't unplug your system, otherwise your system maybe dead. Be careful.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.