Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

While attempting to diagnose another issue (which I asked about over here), I discovered that the apache 1.3.37 installation on a machine I inherited doesn't log 404 errors to error_log. I've scoured the config files for CustomLog and ErrorLog directives, but they're all just the standard 'set a path and (for CustomLog) combined format' type.

It does log other errors normally, such as 'Permission denied', but 404s are silently ignored.

What might be causing this and how can I get the 404s to appear (at least temporarily)?

share|improve this question
1  
Have you checked your access.log for the 404? –  Nifle Jan 2 '12 at 15:12
    
@Nifle: Yes, the request shows in access_log with a 404 status. –  Dave Sherohman Jan 2 '12 at 15:30

2 Answers 2

I turned out that the context of the original issue was relevant here - the problem URL contained the sequence %2F (a URI-encoded forward slash). In an attempt to protect security-oblivious CGI programmers from their own ignorance, apache immediately rejects (as 404 Not found) any requested URL which contains that sequence at a very early stage in the request-handling process, which apparently bypasses any writes to error_log.

share|improve this answer

maybe the CustomLog directive is configured (also check .htaccess files) which excludes 404s.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.