Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a VAIO laptop model VGN-C22GH. It has a built in wireless card with a Intel Centrino processor on his motherboard.

When using Ubuntu 10.04, the wireless indicator blinks violently. This symptom does not appear with earlier versions of Ubuntu like 9.10 or 8.10.

This leads me to believe that it is a driver issue. Is it something that I should worry about?

I have no idea where to look for, since this is a very limited scope problem. Should I report to Cannonical about this problem of mine??

share|improve this question
2  
Probably it's indicating packets that travel over air. Before reporting bug report (it probably is not a bug but feature) try to update to newest version of Ubuntu. –  blogger Jan 2 '12 at 16:37
    
Does the wireless work otherwise? Have you ensured it's not blinking due to network traffic? –  Ƭᴇcʜιᴇ007 Jan 2 '12 at 20:05
    
@blogger: I don;t want to upgrade to 11.10. I hate that newer mouse friendly features in 11.10. :( –  Vineet Menon Jan 3 '12 at 4:42
    
@techie007 : What do u mean by "otherwise". As soon I connect to access point, the LED indicator starts to blink. It could probably also be due to beacon signals sent by AP. I will check that out..thx... –  Vineet Menon Jan 3 '12 at 4:44
    
@blogger: You were right!! It was indicating the packets being sent/received...If you could write that as an answer, I can give you a couple of repo. :) –  Vineet Menon Feb 20 '12 at 10:12

1 Answer 1

You are right, it is a driver issue or rather it's a feature!

According to the documentation (which seems rather hard to find atm) (sudo modinfo -p iwlegacy the driver iwl_legacy has an option led_mode which controls exactly this behaviour (namely blinking on sending/receiving packets).

You can turn it off by creating a file called wifi.conf in /etc/modprobe.d (obviously as root) with the following content:

# Disable blinking
options iwlegacy led_mode=1

Then restart for the change to take effect.
You could also just rmmod and modprobe the iwlegacy and iwl3945 drivers, but that's a tad more complicated.

share|improve this answer
    
can you link me to the docs? –  Vineet Menon Apr 10 '12 at 10:30
    
@VineetMenon: Please see my updated answer. –  phw Apr 10 '12 at 20:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.