Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My mother has a HP DV6000 series laptop, and we never used the wireless card before, but now I bought a WiFi router and would like to use it.

The operating system is Windows 7 Home Premium and it's detecting the device 'randomly'. I don't know what it could be, because I'm working on it for 2 days and the behavior is really unusual.

I've tried to uninstall everything and let the Windows install their own drivers from internet, and also installed the drivers provided by HP and they seems the same.

I tried to diagnose the problem, but i couldn't conclude anything.

I've removed the card, applied fine abrasive on the contacts although they were visually perfectly clean and looking brand-new, and also I'm not touching the physical switch in order to make sure it's not the contact.

Some results points to a software issue, for example, if it's working, sleeping and waking-it up causes the device to disappear from the device manager, and there's no "unknown device" or something, it simply disappears.

Some other points to a hardware issue, for example, it seems to happen on Linux also, sometimes I boot an Ubuntu live-CD and it never lists the WiFi card on lspci or lsusb.

There's no bios entry regarding the WiFi card, in fact the bios is quite simple and there's no option for anything at all, besides video memory.

I don't know if it's possible that it's the motherboard chipset or something else.

I can't figure out what's wrong and fix it by myself, so I'm asking for help. If you have experienced something similar, or know some tests i can do in order to get some clues, please, help me!

Configuration:

Windows 7, Laptop HP (DV6000), Broadcom BCM43xx, Nforce Chipset

Edit:

Oh man, this is getting weirder. I've booted it a lot of times in the 'security mode with network' and the WiFi is always working in this case, then it works again on "normal" mode but only on the next boot. Maybe when the system shuts down on normal mode it causes the device to malfunction?

share|improve this question
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.