Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I work on Dell optiplex 790 that has two graphics cards: embedded Intel (with VGA output) and 'normal' ATI Radeon (with DVI output). Unfortunately only the first one works. Although both cables (DVI and VGA) are connected to my display, when I change mode to DVI, I get a blank screen. I tried to install drivers from the dell site, but problem persists. I was also told to change video settings in bios, but there were no setting related to switching between cards. What could I do now?

share|improve this question
add comment

3 Answers

up vote 4 down vote accepted

first, try re-booting with JUST the DVI connected. it may be that defaulting to VGA as primary is causing you problems. if that still fails, go into your display properties and look for dual monitor settings and see if it's showing up as a second disabled monitor that needs enabling.

Also try getting latest drivers from the AMD/ATi site rather than from Dell. the Dell ones are usually just OEM branded anyway.

http://support.amd.com/us/gpudownload/Pages/index.aspx

if you don't know exactly what RADEON it is, they have an auto detect tool:

http://support.amd.com/us/gpudownload/windows/Pages/auto_detect.aspx

share|improve this answer
    
I disconnected my VGA cable and DVI works. What a simple solution, thanks! –  mrzasa Jan 9 '12 at 7:53
    
glad it worked ;-) –  geocoin Jan 11 '12 at 5:02
add comment

Two quick notes. If you plug a video card into a PCI slot, the BIOS will automatically disable the onboard VGA adapter. Also, if your Optiplex 790 came with two ATI graphic cards, and you can only get a display on one of them, go into the ATI Catalist Control Center and disable crossfire. Then go into your display settings and redetect your display. BaddaBoom, problem solved.

share|improve this answer
add comment

Optiplex 790 Machines will only use the built-in graphics card or an expansion card but not both. You first need to go into the BIOS and disable the integrated graphics. This will allow the BIOS to recognize the card. Bear in mind that because the BIOS was programmed this way on purpose, you cannot run both at once.

share|improve this answer
    
Unfortunalety I couldn't found in BIOS any option related to graphics switching. –  mrzasa Jan 9 '12 at 7:52
    
Do you know which form factor of Optiplex 790 you have? I might be able to get some step by steps if I knew if it was a Ultra-Small, Mini or tower model. –  ChargerIIC Jan 9 '12 at 15:07
    
Thanks for you help, the another comment helped me fixing my issue. –  mrzasa Jan 9 '12 at 15:40
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.