Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently got a new ASUS RT-N10 LX wireless router. I set it up using a wired client. After setting up the router (SSID, authentication, etc.), I got rid of the wired client and I was able to connect to the router wireless. Everything worked fine.

EDIT: But if I restart my wireless client (laptop), I am able to connect to the router wireless but without internet access. I need to reboot the router to get internet to work on the wireless client. Moreover, I forgot to mention earlier that I am behind a proxy. Does it have anything to do with this problem?

Following is the router's log:

Jul 19 11:22:12  klogd started: BusyBox v1.13.4 (2011-07-19 11:18:35 CST)
Jul 19 11:22:12  RTL8192C/RTL8188C driver version 1.4 (2011-03-21)
Jul 19 11:22:16  UPnP: start_UPnP
Jul 19 19:22:19 wlan0: A wireless client is associated - B8:8D:12:07:62:6C
Jul 19 19:22:19 wlan0: WPA-TKIP PSK authentication in progress...
Jul 19 19:22:19 wlan0: A wireless client is associated - B8:8D:12:07:62:6C
Jul 19 19:22:19 wlan0: Open and authenticated
Jan  3 23:23:02 wlan0: A wireless client is associated - B8:8D:12:07:62:6C
Jan  3 23:23:02 wlan0: WPA-TKIP PSK authentication in progress...
Jan  3 23:23:02 wlan0: A wireless client is associated - B8:8D:12:07:62:6C
Jan  3 23:23:02 wlan0: Open and authenticated
Jan  3 23:23:03 wlan0: A wireless client is disassociated - B8:8D:12:07:62:6C
Jan  3 23:33:49 wlan0: A wireless client is associated - 70:F3:95:B4:D2:62
Jan  3 23:33:49 wlan0: WPA-TKIP PSK authentication in progress...
Jan  3 23:33:49 wlan0: A wireless client is associated - 70:F3:95:B4:D2:62
Jan  3 23:33:49 wlan0: Open and authenticated
Jan  3 23:34:04 wlan0: A wireless client is associated - B8:8D:12:07:62:6C
Jan  3 23:34:04 wlan0: WPA-TKIP PSK authentication in progress...
Jan  3 23:34:04 wlan0: A wireless client is associated - B8:8D:12:07:62:6C
Jan  3 23:34:04 wlan0: Open and authenticated
Jan  3 23:40:36 wlan0: A wireless client is disassociated - B8:8D:12:07:62:6C
Jan  4 00:33:54 wlan0: A wireless client is deauthenticated - AC:72:89:4D:FE:31
Jan  4 00:38:23 wlan0: A wireless client is deauthenticated - AC:72:89:4E:0A:34
Jan  4 00:38:59 wlan0: A wireless client is associated - B8:8D:12:07:62:6C
Jan  4 00:38:59 wlan0: WPA-TKIP PSK authentication in progress...
Jan  4 00:38:59 wlan0: A wireless client is associated - B8:8D:12:07:62:6C
Jan  4 00:38:59 wlan0: Open and authenticated

EDIT - 2: Renewing the DHCP lease, doesn't seem to work for me. My computer doesn't get a new IP on renewal. Infact after DHCP lease renewal, the computer is not even able to connect to the router wireless.

share|improve this question
    
Which operating system is the client? –  iglvzx Jan 3 '12 at 17:13
1  
Mac OS X 10.7 (Lion) –  stressed_geek Jan 3 '12 at 17:18
    
Ah. That changes my answer. I will update it in a bit! –  iglvzx Jan 3 '12 at 17:19

4 Answers 4

You should not need to restart your router, unless there is a serious firmware issue.

If your router has DHCP enabled, and your client is set to automatically get addresses via DHCP, running the following should do the same thing as restarting the router:

Windows:

ipconfig /flushdns
ipconfig /release
ipconfig /renew

Mac OSX Lion:

(Thanks @slhck)

sudo killall -HUP mDNSResponder
sudo ifconfig en1 down
sudo ifconfig en1 up

Or from the GUI:

System Preferences » Network » Advanced… » TCP/IP

gui

share|improve this answer
    
Thanks, it would be great if you could post Mac OS X 10.7 (Lion) equivalents of these. I am trying to google it, but different resources are pointing to different OS X equivalents. –  stressed_geek Jan 3 '12 at 17:20
    
I do not use Mac OSX, so I am also having difficulty finding the correct answer. –  iglvzx Jan 3 '12 at 17:38
    
@stressed_geek See the update. –  iglvzx Jan 3 '12 at 21:02
1  
@stressed_geek Ping me if you need to know more or if something doesn't work out. –  slhck Jan 3 '12 at 21:03
    
Thanks for your help. Neither of the approaches you suggested for Mac OSX work for me. After every restart of my computer I have to switch off wireless on my laptop, then restart the router, to get internet to work. –  stressed_geek Jan 5 '12 at 16:52

to get a good image of the situation..

your behind a proxy.. were is the proxy. i.e on wich side of the router?

Is the router talking with the proxy and you with the router or do you talk to the proxy and the proxy goes to the router?

Does the proxy work with credentials?

share|improve this answer

The following questions/suggestions might help:

Is this the same for other wireless devices you connect to the router?

Do your wireless clients get a full IP configuration (IP, gateway, DNS, etc) or are there things missing?

Are you capable of pinging a wired host from your wireless host if it doesn't have internet?

It could be a faulty config on your router. Maybe if you reset it to factory defaults and configure it again it might work.

Temporarily shut down the firewall(s) on your router and wireless clients, it could be that your client firewall doesn't trust the wireless network.

Edit: I don't know if your router keeps logs. Try to access it with SSH/telnet or via the webinterface and look for log and post them here.

share|improve this answer
    
Thanks Robert for your suggestions. 1. This is same for all wireless devices connected to the router. 2. wireless clients are getting full ip configuration. 3. Tried reset to factory settings. Problem still persists. 4. Shutting down the firewall also doesn't help. –  stressed_geek Jan 3 '12 at 13:19
    
Did you try pinging from a wireless client to a wired one? Also, try a traceroute from a wireless client to google.com and a wired client –  Robert Jan 3 '12 at 13:37
    
I tried pining google.com and wired client(192.168.1.2) through the wireless client. Both ping and traceroute fail when I don't have internet on the wireless client. –  stressed_geek Jan 3 '12 at 15:00
    
Sorry for the confusion, but I just realized now that the problem is that every time I restart the wireless client, I need to reboot the router to get internet to work on the wireless client. It doesn't matter if a wired client is connected or not. –  stressed_geek Jan 3 '12 at 15:18
    
I don't know if your router keeps logs. Try to access it with SSH/telnet or via the webinterface and look for log and post them here. –  Robert Jan 3 '12 at 15:38

Try changing the mac's name to something short with no hyphens in it. The "wizard" that runs when you turn on a new mac for the first time gives the machine a long name like richards-mac-mini. Use System Preferences > Sharing to change it to something short like "rsmm" after recording the current name. Doing so worked for me. Note that my wifi router is not an Asus, though.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.