Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to use todotxt in Cygwin on Windows 7. However, when I do t add "test" I get an error message: "Fatal Error: $/cygdrive/c/Users/Travis/todo is not a directory". However, cd /cygdrive/c/Users/Travis/todo" works just fine:

enter image description here

Edit: in my .bashrc file, I have the following: alias t="/cygdrive/c/users/Travis/todo/". Additionally, executing /cygdrive/c/users/travis/todo/ add "test" from the shell fails with the same error message, even though cd /cygdrive/c/users/travis/todo works perfectly well.

share|improve this question
up vote 3 down vote accepted

These are two different paths. The one you configured todo.txt to use has an extra $ at the beginning.

share|improve this answer
I think Cygwin is adding that somehow. In my .bashrc file I have: alias t="/cygdrive/c/users/Travis/todo/", and the following produces the same error when executed from the shell: /cygdrive/c/users/travis/todo/ add "test" – tnorthcutt Jan 3 '12 at 17:03
What TODO_DIR is set in your todo.cfg? – grawity Jan 3 '12 at 17:05
And there was the problem: the relevant line did have the $ at the beginning: export TODO_DIR=dirname "$/cygdrive/c/Users/Travis/todo/todo.txt". I changed that and it works now. – tnorthcutt Jan 3 '12 at 17:15

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.