Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Windows 7 PC with onboard HDMI connected to my Receiver (Pioneer VSX-821K), via HDMI. The Receiver is connected to a fairly new Vizio LCD TV via the HDMI Out on the receiver.

This Setup works great when all of the components are on.

The trouble comes in when I turn off the TV, which I want to do so I can play music from my PC, but not have to waste energy running the TV.

When I turn off the TV, sound stops, sometimes just for a few seconds, but most of the time, it doesn't come back at all.

I'm thinking this is a Windows 7 issue, where Windows sees that the monitor is no longer on and stops sending the HDMI audio signal.

All drivers and Service Packs are up-to-date, and I don't see any relevant settings in the Sound Devices dialogs in Windows.

This is driving me crazy, please help!

UPDATE I ended up resolving this problem by connecting the S/PDIF on my computer to the Receiver and connecting the HDMI out on my computer to my TV. This solution works, but it is not ideal. If anyone reading this knows of how to make a pure HDMI solution work, please comment!

share|improve this question
    
I would suggest adding an S/PDIF optical cable, but that would require too much work every time you wanted to switch to/from listening to music. –  MBraedley Jan 3 '12 at 16:36
add comment

2 Answers

up vote 0 down vote accepted

I have a Sony receiver and experience the same issue. Personally it's not a big deal for me. When you turn off your TV, check your Receiver. Mine will turn off.

However, since I have the same issue and have a wife that can barely find the power button, I needed a better solution. Even though the HDMI cable carries the audio as well, with my setup, I had to get an optical cable from PC to Receiver and HDMI from PC to TV. By doing this, the system was independent of the HDMI cable when it came to audio. I set the digital output as the primary device for my audio output and set Windows to not export audio with HDMI. This solved my woes of having to turn off the TV but keep the audio alive.

enter image description here

share|improve this answer
    
In win7, how do you set it to not export audio with HDMI? –  Matthew Jan 3 '12 at 16:41
    
@Matthew right-click on the volume control icon and select Playback devices. Then set S/PDIF as the default output device. Note that the receiver may not accept video over HDMI and audio over S/PDIF at the same time, meaning that you'd have to switch between the the two outputs on the computer as well as the two inputs on the receiver. –  MBraedley Jan 3 '12 at 17:01
    
I go HDMI to TV and S/PDIF to Receiver. I use the Ceton PCIE tuner card so I never need to switch off of my one input. –  kobaltz Jan 3 '12 at 17:03
    
Got it, yeah, I was aware of the optical cable option, but wanted to avoid it. HDMI sounded more rich than the optical cable. I suspect that my SPDIF card is not sending true 5.1. –  Matthew Jan 3 '12 at 22:32
    
@Matthew, you may be correct. One should not be making those kinds of comments if everything is configured correctly. –  kobaltz Jan 3 '12 at 23:16
add comment

You may want to look at creating a custom EDID-based driver. I gather this fools Windows into thinking one particular HDMI device is on the receiving end, rather than a handshake being performed when you turn off your TV.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.