Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

One of my neighbors has an unsecure wifi network called WLAN. At one point in the past, I accidentally connected to it, and disconnected immediately when I noticed. Now, when I open my laptop at home, it sometimes connects to the WLAN network first, before trying my (secured) home wifi network.

The information I've found regarding this issue seems to suggest this network should have a profile on the "Manage wireless networks" screen - but it does not.

How do I tell Windows 7 to never connect to networks with SSIDs called WLAN? Or to never connect to unsecured networks without confirming with me first?

share|improve this question
    
The is really no network called WLAN if you try: start, type manager wireless networks? –  Robert Jan 3 '12 at 19:26
    
That is strange. It should show up in Control Panel\Network and Internet\Manage Wireless Networks. –  iglvzx Jan 3 '12 at 19:27
1  
The simple solution is to log into the remote configuration for the router ( likely the default password ) and change the settings. –  Ramhound Jan 3 '12 at 20:04
    
No, not in Control Panel\Network and Internet\View Network Status and Tasks\Manage Wireless Networks. I even checked each network entry's properties individually in case the SSID was different than the display name for some reason. –  Remi Despres-Smyth Jan 3 '12 at 21:55
    
Strange, this is not the default behavior. . . –  surfasb Jan 4 '12 at 0:41
add comment

3 Answers

up vote 4 down vote accepted

From this Microsoft MVP:

To block a neighbor's unencrypted wireless network called WLAN, type this in a command window as an administrator:

netsh wlan add filter permission=block ssid=WLAN networktype=infrastructure

I just had it again: after a reboot, Windows 7 automatically connected to a public open (but non-working) network I have never connected to, and I didn't have any option (in the UI) to prevent that. The command above (with the network name in double quotes instead of WLAN) completely removed the network from Windows' radar!

share|improve this answer
add comment

There should be an option in the Manage Wireless Networks window, if not you can do one of these:

  1. Delete all shown networks there
  2. Disable the wireless device from Device Manager (right click on My Computer > Manage > Devices/Device Manager)
  3. Uninstall the device then install it again
share|improve this answer
add comment

Go to Control Panel > All Control Panel Items > Network and Sharing Center > Manage Wireless Networks (in the left pane) and right-click the one you want to change, then click Properties > Connection Tab.

There are three fields that can be changed: Connect automatically when in range, Connect to a more preferred network and Connect even if the network is not broadcasting. Change them accordingly.

(If you have difficulty finding the "Network and Sharing Center" you can also just click windows butten and just below "all programs" use the search bar and type it in. That's what I did)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.