Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to install the ssh extension of PHP following this article.

My machine is a Linux mpriki 2.6.26-2-686 #1 SMP Mon Jun 21 05:58:44 UTC 2010 i686 GNU/Linux (lenny13 distrubition

When I type aptitude install libssh2-1-dev libssh2-php everything seems to be OK, but when I run php -m |grep ssh2, the shell doesn't return anything, so I tried to follow the alternative installation.

First of all, I tried to download it with wget from here: http://surfnet.dl.sourceforge.net/sourceforge/libssh2/libssh2-0.14.tar.gz, but there was no file to download, so I tried another link: http://www.libssh2.org/download/libssh2-0.14.tar.gz

Then, when I type pecl install -f ssh2 is see the following message:

root@mpriki:~# pecl install -f ssh2
WARNING: failed to download pecl.php.net/ssh2 within preferred state "stable", will instead download version 0.11.3, stability "beta"
downloading ssh2-0.11.3.tgz ...
Starting to download ssh2-0.11.3.tgz (23,062 bytes)
........done: 23,062 bytes
5 source files, building
running: phpize
Configuring for:
PHP Api Version:         20041225
Zend Module Api No:      20060613
Zend Extension Api No:   220060519
 1. libssh2 prefix? : autodetect

1-1, 'all', 'abort', or Enter to continue:

I find this on superuser but when I run aptitude install libssh2-1-dev, it seems the package has been already been installed.

Edit: I found this link but even though I don't know what to do.

share|improve this question
add comment

2 Answers

1-1, 'all', 'abort', or Enter to continue:

Enter a number (between 1 and 1) to install that module from the list; or the word "all" to install all found modules; or "abort" to abort installation.

share|improve this answer
    
yes but then (type 1) i see this libssh2 prefix? [autodetect] –  user726730 Jan 3 '12 at 23:13
    
...Enter a prefix where you want libssh2 to be installed to, or press Enter to have the best prefix auto-detected. –  grawity Jan 3 '12 at 23:30
add comment

I would just do phpseclib, a pure PHP SSH implementation, if possible. It's easier to install, easier to use, more feature packed and faster even then libssh2.

share|improve this answer
    
i now this library, anyway i found the solution in my problem.. The problem was in ssh2.c file A patch file must be included –  user726730 Jan 4 '12 at 23:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.