Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a site which only functions in IE9/Chrome/Firefox. The site is an internal only site from a vendor, so we access it by https://serverName/ -- IE9 correctly identifies this as an intranet site, but for reasons I cannot explain it is reporting it self as IE8. The site sees this and won't let me log in.

Is there a way that I can tell IE9 to stop reporting itself as IE8 for this site?

For the record, the software is PRTG Monitoring... so if there are other ways to work around it I'm good with that too.

update

This is what I see when I open the site:

enter image description here

If I change Browser Mode from IE9 Compat View to IE9 and refresh, the website works as expected. As you see here, I have no Compatibility View button in my address bar to change. I had to go to the developer tools to switch modes. This only fixes it until I close and open the browser again though.

If I access the site by its local IP address instead of https://serverName/ IE correctly runs in the right mode and the site works fine.

share|improve this question
    
Have you tried this from more than one computer? Have you tired resetting IE9 to defaults? –  Ƭᴇcʜιᴇ007 Jan 4 '12 at 0:52
1  
Tell us what res://iecompat.dll/iecompatdata.xml tells you, and what checkboxes are checked in your "Compatibility View Settings" (accessible from the Tools menu) dialogue. –  JdeBP Jan 4 '12 at 18:54
    
@JdeBP, that was it. res://iecompat.dll/iecompatdata.xml comes up with connection error, but under Compatibility View Settings there was a checkbox for "Run Intranet sites in Compatibility Mode" I removed that check, and it's working exactly it should. Post that up as an answer so I can accept it. –  Nate Jan 4 '12 at 20:47

4 Answers 4

up vote 3 down vote accepted

In the Tools menu on the command bar there is an entry that brings up the Compatibility View Settings dialogue. Ensure that the "Display intranet sites in compatibility view" checkbox is unchecked.

Further reading

share|improve this answer

Check if your "Compatibility View" button is active.

share|improve this answer
    
No, the button is not even visible on the screen. –  Nate Jan 4 '12 at 16:12

I had to install a plugin to get IE9 to identify it as IE8. I didn't find any other way to override the identification. Check the plugin you are using and see if you can get it to change its response depending on which site it is visiting.

I really dislike software which gets overly restrictive on which browser or plugin it works with. I had to install the plugin to run software that check the browser version to ensure it is IE 5, 6, 7, or 8. It works fine under IE9 but refuses to run if it knows that is the browser version.

EDIT: Thanks for the question. My issue is the revers of yours. Need full Compatability View if I don't fake the browser string. This is enabled by selecting Display all websites in Compatibility View from the Tools -> Compatability View Settings menu tab. This will disable the Tools -> Compatability View item as all items will be in Compatability View mode. Disable this if you have it set. Selecting this mode makes my problems go away even when the plugin is disabled.

In the Tools -> Compatability View Settings menu tab there is a list of domains to view in Compatibility View mode as well as a selection for Displayy intranet sites in Compatibility View. Either of these would put your application in Compatibility View mode if you select Tools -> Compatiblity View from the menu.

share|improve this answer
    
No plug-ins for changing browser modes. Flash, Silverlight, etc... nothing special or unusual. –  Nate Jan 4 '12 at 16:20

Go to Tools/Internet Options/Security/Sites/Advanced/https

enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.