Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Is there a proper and permanent fix that will restore the display of Chinese Characters on a Windows 7 Home Premium Laptop computer? This problem has been occurring frequently now and a simple reboot no longer does the trick. The square boxes viewed on many applications and websites has been constantly bothering me and I wish to fix it asap. I have done a lot of research on it but have not been successful. Many responses were to install the language packs for Windows 7 Ultimate Users which apparently is not my case or to configure the "Region and Language" settings of the Control Panel, changing the system locale.

Does anyone have any suggestions? All would be appreciated!

share|improve this question
    
Which applications? When does it happen? Error messages show up?? –  surfasb Jan 4 '12 at 16:42
    
All applications such as Windows Media Player and Web Browsers (Google Chrome and Mozilla Firefox). It has happened on every single start-up now and square boxes are constantly displayed on the screen in place of the Chinese characters that is suppose to appear. –  David Jan 5 '12 at 5:54
add comment

2 Answers

up vote 5 down vote accepted
+50

There are many reasons for this kind of a problem, so here are some ideas :

  1. Go back to a restore point before the problem occurred.
  2. Boot in Safe mode. If the problem disappears then some installed product is causing the problem.
  3. If the problem is font cache corruption, delete the file C:\WINDOWS\system32\FNTCACHE.DAT and reboot.
  4. Reinitialize fonts via Control Panel => Fonts, click on Font Settings, unchceck Hide fonts based on language setting, then click on Restore Default Font Settings.

Please let me know the results of these manipulations. I advise creating a system restore point before starting, just in case.

share|improve this answer
    
I booted into Safe mode and the problem still existed. I am unsure what exactly is causing this issue. I then tried method # 4 and it was a temporary fix for the most part. The problem reappeared after three restarts. –  David Feb 1 '12 at 23:39
    
What would be the best way to diagnosis this problem? –  David Feb 1 '12 at 23:45
    
Nobody ever figured out the cause for this problem or how to diagnose it. Many of the solutions that work for other people are impossible on Windows Home, such as moving to a new user profile. To avoid this problem some people always repeat an operation such as deleting fntcache.dat before turning off the computer. Some others have even reinstalled Windows, only to see the problem return after some time, although for others this did definitely fix the problem. So if worse comes to worse, you may just need to repeat method #4 every few days. –  harrymc Feb 2 '12 at 8:18
    
@harrymc, is there a convenient way to get such a script to run at shutdown? –  soandos Feb 2 '12 at 13:53
    
You could program it using for example AutoHotkey. –  harrymc Feb 2 '12 at 14:37
show 1 more comment

Try this:

  1. Go to control panel -> appearance and personalization -> Fonts .
  2. Select all and show them (not hide them).
  3. Left Side of panel shows Font settings click on it.
  4. Uncheck/Untick Hide fonts base on language settings.
  5. Reboot and see if it works.

This worked for me.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.