Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed VirtualBox with the RPM from http://virtualbox.org ; but when I tried to setup and run a VM it said that the VirtualBox service was not started (vboxdrv) and told me to sudo /etc/init.d/vboxdrv setup; but that failed to install the driver.

What should I do now? Reinstalling the driver through vboxdrv setup isn't working, vbox restart didn't do anything; should I remove VirtualBox and try reinstalling it? If so, how? I'm kinda new to Linux, is there an uninstall utility for Fedora?

Output of vboxdrv setup (abbreviated)

Installing new VirtualBox modules via DKMS [  FAILED  ]
(trying without DKMS)
Recompiling VirtualBox kernel modules      [  FAILED  ]
share|improve this question
    
Can you expand on it failing? Any errors? –  kobaltz Jan 4 '12 at 23:14
    
do you have DKMS installed? (yum install dkms maybe) –  kobaltz Jan 4 '12 at 23:34
    
Or you could try to install virtualbox from Fedora's packages if available. yum install virtualbox-ose –  kobaltz Jan 4 '12 at 23:35

1 Answer 1

up vote 0 down vote accepted

Turns out that vboxdrv needs to have gcc and dkms installed; I had neither.

After installing dkms and gcc, it worked.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.